Installare Apache 2, PHP 5, MySQL 4.1 su Windows

Adesso mi trovo alla pagina 6 del tutorial per configurare apache2

php5 e mysql 4.1.8 e non riesco nonostante segua passo passo le

istruzioni a far caricare ad php l'estensione mysqli, cosa sbaglio?

Inoltre anche ieri sera ho provato a copiare il file libmysql.dll nella cartella di windows ripetendo il tutto, modificando il file php.ini. Ma php non carica alcuna estensione

Lavoro su windows XP HE

inviato 11 anni fa
marig
X 0 X

Che versione di PHP usi? La 5.0.3?

Qual'è precisamente l'errore che ricevi? e quando?

risposto 11 anni fa
Gianni Tomasicchio
X 0 X

La versione è php 5.0.3 non ricevo alcun segnale di errore soltanto al momento della verifica digitando l'indirizzo http://localhost/info.php. PHp non carica le estensioni mysqli o mysql a metà pagina.

risposto 11 anni fa
marig
X 0 X

Domanda stupida: hai riavviato Apache?

risposto 11 anni fa
Gianni Tomasicchio
X 0 X

Si certamente ho effettuato Restart dopo aver cliccato sull'icona di Apache. Ho seguito tutta la procedura a pag. 6 passo passo

risposto 11 anni fa
marig
X 0 X

Quando hai installato PHP, hai inserito la riga

PHPIniDir "C:/php"

nel file httpd.conf?

Puoi riportare (o allegare) il tuo php.ini?

risposto 11 anni fa
Gianni Tomasicchio
X 0 X

Si avevo inserito il riferimento, allego il file php.ini ma come? Non vedo nulla che mi permetta di allegare copiare il file non si può

risposto 11 anni fa
marig
X 0 X

Gianni ho mandato file php.ini come allegato per posta all'indirizzo di webmaster

risposto 11 anni fa
marig
X 0 X
Si avevo inserito il riferimento, allego il file php.ini ma come? Non vedo nulla che mi permetta di allegare copiare il file non si può

hai ragione, gli allegati sono disabilitati, provvedo subito. Troverai l'opzione tra le "Opzioni addizionali" della pagina per le risposte.

risposto 11 anni fa
Gianni Tomasicchio
X 0 X

Svelato l'arcano  ;)

marig non si era accorta di avere la versione 5.0.1 di PHP che richiede libmysqli.dll e non libmysql.dll (necessaria invece per PHP 5.0.3 e successivi)

risposto 11 anni fa
Gianni Tomasicchio
X 0 X

Grazie Gianni per la tua pazienza ed assistenza, ho ripreso le fila stasera conto di continuare il lavoro. Non è semplice spero di farcela ^-^

risposto 11 anni fa
marig
X 0 X

Salve ottimo tutorial.

Scusate la mia totale ignoranza in materia, ma come faccio per aprire il phpmyadmyn?

per creare un database?

Grazie

risposto 11 anni fa
Rino
Rino
1
X 0 X

Grazie per l'apprezzamento  ;)

Hai già installato phpMyAdmin?

Se hai dei problemi con phpMyAdmin comunque sarebbe meglio che tu aprissi una nuova discussione, magari nella sezione "Database".

Bye

risposto 11 anni fa
Gianni Tomasicchio
X 0 X

Di niente.

no non ho installato il phpmyadmin non so nemmeno da dove iniziare hehe

Comunque credo di avere dei problemi qui sul mio computer, tispiego avevo installato easyphp non mi é piaciuto, ho disinstallato e ho installato appserv ma niente non funziona affatto,ora seguendo il tutorial qui sono riuscito a installare il tutto (anche se ho problemi che credo di risolvere solo formattando perche mi da come se avessi installato 3 apache)

Per quanto riguarda il phpmyadmin potresti darmi qualche consiglio su come installarlo e da dove scaricarlo?

Grazie mille

risposto 11 anni fa
Rino
Rino
1
X 0 X

Questo articolo che abbiamo scritto fa al caso tuo:

http://www.phpnews.it/content/view/117/80/

Buona lettura!  :D

risposto 11 anni fa
Gianni Tomasicchio
X 0 X

Grazie

sei stato gentilissimo

risposto 11 anni fa
Rino
Rino
1
X 0 X

Adesso mi trovo alla pagina 6 del tutorial per configurare apache2

php5 e mysql 4.1.8 e non riesco nonostante segua passo passo le

istruzioni a far caricare ad php l'estensione mysqli, cosa sbaglio?

Inoltre anche ieri sera ho provato a copiare il file libmysql.dll nella cartella di windows ripetendo il tutto, modificando il file php.ini. Ma php non carica alcuna estensione

Lavoro su windows XP HE

Ho praticamente lo stesso problema...ho provato a risolverlo km detto nei suggerimenti fatti in qsto topic, ma non riesco...ke devo fare?????

Aiutooooooooooooooooooooooo

risposto 10 anni fa
pagnoz
X 0 X

verifica che il file php.ini che stai modificando è veramente quello che PHP prende in considerazione per leggere le impostazioni.

Per farlo controlla 2 cose: fatti mostrare da Windows le estensioni di utti i file, a volte infatti la vera estensione del nome del file viene nascosta e quindi si modifica il file sbagliato.

Per vedere quale php.ini il PHP sta utilizzando basta creare e lanciare un piccolo script:

<?php
phpinfo();
?>

Nella schermata che ti verrà mostrata controlla, tra le prime righe, il falore della direttiva "Configuration File (php.ini) Path". Punta al tuo php.ini?

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

verifica che il file php.ini che stai modificando è veramente quello che PHP prende in considerazione per leggere le impostazioni.

Per farlo controlla 2 cose: fatti mostrare da Windows le estensioni di utti i file, a volte infatti la vera estensione del nome del file viene nascosta e quindi si modifica il file sbagliato.

Per vedere quale php.ini il PHP sta utilizzando basta creare e lanciare un piccolo script:

<?php
phpinfo();
?>

Nella schermata che ti verrà mostrata controlla, tra le prime righe, il falore della direttiva "Configuration File (php.ini) Path". Punta al tuo php.ini?

Punta a c:windows...xk?dove deve puntare????????

risposto 10 anni fa
pagnoz
X 0 X

se hai seguito la nostra guida doveva puntare a C:\php\php.ini che dovrebbe essere il file che stai modificando, o no?!?

risposto 10 anni fa
Gianni Tomasicchio
X 0 X
se hai seguito la nostra guida doveva puntare a C:\php\php.ini che dovrebbe essere il file che stai modificando, o no?!?

Ho cancellato tutto...ho rimesso tutto e ora carica il tutto alla perfezione...l'importante ora è la sintassi di php5!!!

Grazie a tutti e all'autore della guida!!!

Grazie a presto! ;) ;) ;)

risposto 10 anni fa
pagnoz
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda