Installare Apache 2, PHP 5, MySQL 4.1 su Windows

Ho seguito la procedura aiutata da gianni dopo avere installato  Apache versione 2.0, configurato Php versione 5.03,  eccomi a Mysql con difficoltà insuperabili. Lanciato il programma  da mysql command line con la password testpass e digitata la stringa, mysql mi da errore perchè dice che la versione non è quella giusta ma dai dati ottenuti lanciando il file info.php la versione di mysql e 4.1.7 mentre da mysql command line la versione risulta 4.1.8 per cui non riesce a connettersi quando lancio il http://localhost/testmysql.php. Non capiso cosa succeda ho riprovato tante volte ma niente da fare. Help me.

inviato 11 anni fa
marig
X 0 X

Ciao marig,

se ho ben capito stai cercando di installare l'estensione "mysql". Vero? Ti ricordo che questa estensione non è quella più adatta per le versioni MySQL 4.1 e successive che invece dovrebbero essere usate attraverso l'estensione "mysqli"

La procedura mostrata nell'articolo è una sorta di stratagemma per superare questa incompatibilità. E' strano però che non abbia funzionato nel tuo caso. Sarebbe utile se tu riportassi esattamente la procedura che hai seguito (passo passo) e l'errore che hai ottenuto.

Comunque, se vuoi usare l'estensione "mysql" (necessaria se vuoi provare a far girare gli script non troppo recenti) e se non ti importa di provare il nuovo MySQL 4.1 allora puoi tranquillamente installare MySQL 4.0. Questa versione infatti è supportata nativamente dall'estensione "mysql" e non dovrai fare nessuno stratagemma (quella roba da digitare al prompt di MySQL) per farlo funzionare.

A presto

risposto 11 anni fa
Gianni Tomasicchio
X 0 X

Proverò stasera con l'altra estensione mysqli e ti farò sapere. Ciao e grazie, non voglio passare ad una versione antecedente di Mysql

risposto 11 anni fa
marig
X 0 X

Aggiornamento:

con le più recenti versioni di PHP (dalla 5.0.3) l'estensione mysql è completamente compatibile con MySQL 4.1 anche se ovviamente non ne può supportare le funzionalità avanzate. Questo significa che gli script PHP che usano l'estensione mysql sono pienamente comaptibili con MySQL 4.1

risposto 11 anni fa
Gianni Tomasicchio
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda