Problema PhpMyAdmin

Ho installato nuovamente (dopo aver formattato e installato il servise pack2)Apache server, php e Mysql e fin qui tutto bene;

Ho scompattato anche il phpMyAdmin nella cartella httdocs di Apache ma, se provo ad accedere all'index.php del phpMyAdmin mi da il seguente errore:

Errore

Messaggio di MySQL:

Access denied for user 'root'@'localhost' (using password: NO)

io credo sia un problema di firewall ma, non so come aggiungere il mysql alle eccezzioni di windows firewall (non conosco nè il nome nè la porta).

Spero possiate aiutarmi, a presto!

inviato 11 anni fa
yusizu
X 0 X

non è un problema di firewall perché la connessione è avvenuta, tant'è che è stato verificato username e password, ma non sono corretti!

L'errore dice che l'accesso da parte dell'utente "root", che sta usando una password vuota, non è consentito.

Devi semplicemente inserire la password di root che hai impostato al momento dell'installazione di MySQL.

 :bye:

risposto 11 anni fa
Gianni Tomasicchio
X 0 X

Scusami se ho postato due volte ma, mi è uscito un messaggio che mi indicava che la sessione era andata in time out.

Ma la password di root dove devo metterla??

Perchè io non faccio altro che digitare il seguente url: http://localhost/phpmyadmin/index.php

Grazie ancora!

risposto 11 anni fa
yusizu
X 0 X

Leggi prima questa guida su phpMyAdmin:

http://www.phpnews.it/content/view/117/80/

li troverai la risposta  :bye:

risposto 11 anni fa
Gianni Tomasicchio
X 0 X

Leggi prima questa guida su phpMyAdmin:

http://www.phpnews.it/content/view/117/80/

li troverai la risposta  :bye:

Scusami se insisto ma, l'unica cosa che ho trovato è stata l'incompatibilità di PhpMyAdmin con MySQL 4.1 che è la versione che ho io!

Però, questa è la seconda volta che installo i seddetti progammi e, la volta precedente, con gli stessi programmi e, con la password di MySQL (testpass) che suggerisci nella guida, non ho dovuto fare altro che scompattare la cartella e, aprire il file index.php....(fortuna?)

Spero tanto possa darmi qualche dritta un pò più dettagliata, a presto! :'(

risposto 11 anni fa
yusizu
X 0 X

L'incompatibilità è solo per le versioni 4.1.0 e 4.1.1, non per tutte le versioni 4.1.x

La versione attuale è la 4.1.12

Ti ripeto che se leggi la guida, sopratutto la parte che riguarda la configurazione di phpMyAdmin e le varie tecniche dia utenticazione, non avrai problemi.

Il problema è sicuramente nel file di configurazione di phpMyAdmin nel quale devi impostare il metodo di autenticazione. Se scegli l'autenticazione con i cokies allora nome utente e password ti verranno chiesti al momento dell'accesso al programma, altrimenti questi dati andranno inseriti all'interno del file di configurazione.

P.S.: per MySQL 4.1 e successivi è consigliato usare l'estensione mysqli (che va abilitata in php.ini) e va impostata nel file di configurazione di phpMyAdmin

 :bye:

risposto 11 anni fa
Gianni Tomasicchio
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda