Installazione PHP 4.4.0 + MySQL

Ho seguito la guida per installare PHP5, però installando PHP4, e mi fermo quando devo trovare il file:

php_mysqli.dll

oppure

php_mysql.dll

nella cartella extensions in C:\php\ non esistono ho fatto una ricerca in tutto il disco e non li trovo, che cosa devo fare per interfacciare MySQL con PHP 4.4.0?

Ciao by Truzzone  :(

inviato 11 anni fa
Truzzone
X 0 X

Non sono necessari per la connessione a MySQL, basta creare un stringa di connessione all'host e funzionerà tutto.  O0 ^-^

risposto 11 anni fa
EKELON77
X 0 X

Questo il risultato:

Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client in C:\Programmi\Apache Group\Apache2\htdocs\mysql.php on line 2
Connessione non riuscita: Client does not support authentication protocol requested by server; consider upgrading MySQL client

Di:

<?php
   $connessione = mysql_connect("localhost", "root", "prova")
       or die("Connessione non riuscita: " . mysql_error());
   print ("Connesso con successo");
   mysql_close($connessione);
?>

 :'(

Che cosa sbaglio? che cosa devo fare?  ???

risposto 11 anni fa
Truzzone
X 0 X

Per facilitare tutto non conviene installare un "pacchetto" completo come appserv, easyphp o simili? :coolsmiley:

 :bye:

risposto 11 anni fa
z3ro
z3ro
1
X 0 X

Prima cosa ho notato che nel tuo codice manca il nome del db,

comunque guarda come mi connetto io

<?
  $host       = "localhost";
  $db         = "gestvideoteca";
  $dbuser     = "videousers";
  $dbpassword = "";

$connessione=mysql_connect($host,$dbuser,$dbpassword)
or die ( "<span class='red'>Non riesco a connettermi a <b>$host</span>");

mysql_select_db ($db,$connessione)
or die ( "<span class='red'>Non riesco a selezionare il db <br></span>");
?>

Oppure puoi utilizzare pacchetti completi come ti è stato consigliato, se non vuoi  :wallbash:.O0

risposto 11 anni fa
EKELON77
X 0 X

Evitate accuratamente di installare pacchetti tipo easyphp e simili, vi metterete in un mare di guai e presto o tardi ve ne accorgerete. Per l'installazione vedete qui:

http://www.phpnews.it/content/view/67/80/

Se non avete un motivo ben preciso, installate PHP 5.

 :bye:

risposto 11 anni fa
Gianni Tomasicchio
X 0 X

Ciao a tutti, questo è il mio primo post e sono anch'io alle prime armi col php.

Per compatibilità di ambiente di lavoro ho la necessità di usare PHP 4.4.0 ed usando le istruzioni sopra postate non riesco a connettermi al DB, anche settando un utente con il sistema old_password.

Il messaggio di errore è quello postato dalla persona(non ricordo) che ha aperto il 3ad.

Help me !!!!!!

 :bye: :bye: :bye: :bye: :bye:

risposto 11 anni fa
skywalker71
X 0 X

Per compatibilità di ambiente di lavoro ho la necessità di usare PHP 4.4.0 ed usando le istruzioni sopra postate non riesco a connettermi al DB, anche settando un utente con il sistema old_password.

Il messaggio di errore è quello postato dalla persona(non ricordo) che ha aperto il 3ad.

Che versione di MySQL stai usando?

risposto 11 anni fa
Gianni Tomasicchio
X 0 X
Che versione di MySQL stai usando?

4.1.12 Server

4.1.5 gamma Client

Rilevate da DBTools Manager.

risposto 11 anni fa
skywalker71
X 0 X

Hai segutio questi metodi?

http://dev.mysql.com/doc/mysql/en/old-client.html

 :bye:

risposto 11 anni fa
Gianni Tomasicchio
X 0 X

Hai segutio questi metodi?

http://dev.mysql.com/doc/mysql/en/old-client.html

 :bye:

Adesso mi dà un errore di scelta del db.

Probabilmente l'utente non ha i permessi su quel DB.

Faccio delle prove e faccio sapere...

Grazie!!!

risposto 11 anni fa
skywalker71
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda