Problemi con php5.0.5

Salve ho installato da poco php5.0.5 e Apache2.0.54 su windows XP.

Mi sembra di aver seguito correttamente tutte le procedure d'installazione, ma quando cerco di aprire una banalissima pagina di prova http://localhost/index.php, contenente il seguente codice:

<?php

phpinfo();

?>

si apre la finestra di download del file.

Non so proprio cosa fare spero in un vostro aiuto per risolvere l'inconveniente.

Ringrazio in anticipo tutti coloro che risponderanno e in particolar modo lo staff di PHPNews.it che rende possibile tutto questo.

inviato 11 anni fa
SkipperOne
X 0 X

Ciao SkipperOne,

se ti viene chiesto di scaricare la pagina significa che Apache non l'ha riconosciuta come script PHP. E questo significa che il file di configurazione di Apache non è stato modificato correttamente, oppure che l'hai fatto ma non hai riavviato Apache.

Segui questa quida per verificare di aver fatto tutto il necessario:

http://www.phpnews.it/content/view/67/80/

Se hai ancora problemi siamo qui  ;)

 :bye:

risposto 11 anni fa
Gianni Tomasicchio
X 0 X

Ciao Gianni, grazie per la dritta mi è stata molto utile.

Effettivamente nei ripetuti tentativi di trovare la giusta configurazione, ho sbagliato a scrivere una parola nel file "httpd.conf".

Il proplema di fondo era causato dalla libreria "php5ts.dll" che sul mio Windows XP sembra funzionare solo nella cartella "system32".

Ti ringrazio per la velocità della risposta, spero di poter contare ancora su di te se capitano altre situazioni del genere.

 :bye:

risposto 11 anni fa
SkipperOne
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda