Problema con le risorse di rete

Ho un problema che non riesco a risolvere... HELP ME!!!

Il fatto è che non risco ad accedere tramite script ad una risorsa di rete, un disco precisamente. L'accesso mi serve per effettuare una copia di un file sul mio disco locale. Non riuscendo a capire il motivo del non funzionamento da script, ho fatto eseguire un file bat all'interno dello script che effettuasse tramite comandi dos la copia del file, e ho monitorato l'output.

- codice del file bat

cd\

o:

cd \prova\

copy 1.php c:\prova\

- Output

c:\programmi\apache group\apache\test>cd\

C:\>o:

C:\>cd \prova\

C:\prova>copy 1.php c:\prova\

Impossibile trovare il file specificato.

dall'output si può notare che non viene eseguito il comando di passaggio da C a O (o:)

Non ho proprio idea del motivo, non è una questione di permessi poichè eseguendo direttamente in dos il file bat non vi è nessuna anomalia, e il file viene correttamente copiato.

Non so se devo settare nelle impostazioni di PHP o di Apache qualcosa di particolare per permettere la visione delle risorse di rete! Spero che qualcuno possa aiutarmi!

inviato 11 anni fa
actarus1981
X 0 X

Spero che qui vada bene... e spero soprattutto che qualcuno riuscirà a darmi un aiuto!  ???

risposto 11 anni fa
actarus1981
X 0 X

Lo fai eseguire con una chiamata alla shell?

Hai provato:

copy o:\prova\1.php c:\prova\1.php

L'utente che esegue il file bat, credo che sia apache/IIS ha i permessi di accesso?

Edit:

Cavoli, come arrivo tardi!

risposto 10 anni fa
LonelyWolf
X 0 X

Stiamo riesumando topic "stagionati"  ;D

risposto 10 anni fa
Gianni Tomasicchio
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda