Installazione MySQL 5.0.16

Ciao a tutti! ^__^

Son due-tre giorni che sto sbattendo la testa di fronte ad un problema capitatomi dopo l'installazione di Apache 2.0.55, PHP 5.1.1 e MySQL 5.0.16...

Tutti e tre i pacchetti si installano correttamente, vengono configurati dal sottoscritto seguendo le direttive riportate anche in questo sito (a proposito, ottima guida, veramente ben scritta!) e non mi ritrovo di fronte a nessun messaggio d'errore... solamente che la funzione phpinfo() alla voce MySQL e MySQLi mi dice:

mysql

MySQL Support enabled

Active Persistent Links  0 

Active Links  0 

Client API version  4.1.7 

Directive Local Value Master Value

mysql.allow_persistent On On

mysql.connect_timeout 60 60

mysql.default_host 127.0.0.1 127.0.0.1

mysql.default_password no value no value

mysql.default_port 3306 3306

mysql.default_socket no value no value

mysql.default_user no value no value

mysql.max_links Unlimited Unlimited

mysql.max_persistent Unlimited Unlimited

mysql.trace_mode Off Off

mysqli

MysqlI Support enabled

Client API version  4.1.7 

MYSQLI_SOCKET  /tmp/mysql.sock 

Directive Local Value Master Value

mysqli.default_host 127.0.0.1 127.0.0.1

mysqli.default_port 3306 3306

mysqli.default_pw no value no value

mysqli.default_socket no value no value

mysqli.default_user no value no value

mysqli.max_links Unlimited Unlimited

mysqli.reconnect Off Off

quando invece la versione di MySQL installata è ben successiva..

Visto che vorrei provare le novità della versione 5... qualcuno mi sa dire se tutto questo è normale (cosa che non credo, visto che un amico, che ha appena installato il tutto su Linux, non riceve queste notifiche errate) ?

Grazie a tutti, in ogni caso! ^_*

inviato 11 anni fa
AVRstudio
X 0 X

Dimenticavo... nel caso servisse specificarlo, che il S.O. è Windows XP Professional SP2

^_^

risposto 11 anni fa
AVRstudio
X 0 X

quel numero di versione non si riferisce a MySQL ma alla versione della libreria usata dall'estensione mysql per collegarsi al server MySQL. Non preoccuparti, è tutto Ok!  O0

 :bye:

risposto 11 anni fa
Gianni Tomasicchio
X 0 X

Uhmmm... ok ok, allora vuol dire che le librerie che utilizza php sotto Windows son più vecchiotte, almeno formalmente, rispetto a quelle incluse nei pacchetti per linux -_-'

E dire che son giorni che cerco di capire il motivo -_-'

Grazie mille comunque, mi hai risolto un problemone! ^__^

risposto 11 anni fa
AVRstudio
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda