aituo su installazione php...

spero di avere postato nella sezione giusta.... ho questo problmea, su + pc..  uno con win server e win xp pro, installo, apache, mysql, e quando vado a inst il phpfà la copia dei file e poi appare una finestra con sù scritto: che a casua di un errore nn è possibile installarlo... cosa può essere?

inviato 10 anni fa
mrbu
mrbu
1
X 0 X

il php lo stai installando sul disco c?

hai abbastanza spazio?

che errore ti da?

 :bye:

risposto 10 anni fa
thepooh
X 0 X

Segui questa guida:

http://www.phpnews.it/content/view/67/80/

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

certo che ho spazio, comunque stò usando la versione installer.

l' errore dice:

apache configuration: sorry, the software to automatically configure the apache httpd.conf file has not been written. You will have to configure apache manually. See the install txt file for more details.

help me!!

risposto 10 anni fa
mrbu
mrbu
1
X 0 X

 :crazy: questa discussione si è un po' incasinata...

visto che è stata aperta da mrbu è giusto che si continui a parlare solo del suo problema. Sposto gli altri messaggi in una nuova discussione.

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

Lascia perdere l'installer, con Apache è praticamente inutile, anzi è incompleto (nota le dimensioni dell'installer e del pacchetto zippato)

Se stai installando PHP 5 segui alla lettera la nostra guida:

http://www.phpnews.it/content/view/67/80/

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

ok grazie di tuto, ora scarico il paccheto senza installer e provo.. poi riferisco..

risposto 10 anni fa
mrbu
mrbu
1
X 0 X

si funziona, l' ho installato e ho fatto le pag di test.... ora il problema è questo.. ho installato anche il mysql in versione installer... ma da dove ci accedo al mysql??? :uglystupid:

risposto 10 anni fa
mrbu
mrbu
1
X 0 X
si funziona, l' ho installato e ho fatto le pag di test.... ora il problema è questo.. ho installato anche il mysql in versione installer... ma da dove ci accedo al mysql??? :uglystupid:

Questo è un altro problema e quindi necessita l'apertura di un'altra discussione.

Però prima dai un'occhiata a questo thread (non fermarti ai primi messaggi) dovresti trovare i chiarimenti che cerchi:

http://www.phpnews.it/forum/index.php?topic=425.0

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

ciao a tutta la comunità e buon anno;

ho trovato questo post, anzichè aprirne un altro con lo stesso titolo.

Torno dopo qualche mese di assenza in questo forum in quanto avevo provato ad installare il PHP su IIS ma non era andata a buon fine la cosa; mi ero scoraggiato e.... scopro dall'ottimo tutorial scritto nel sito che adesso non ci sono + problemi a far girare le pagine php su IIS.

Dunque.... vi chiedo un pò di pazienza (ringrazio in anticipo x questo )  perchè sono un neo - neo - neofita in fatto di PHP.  Nel tutorial è scritto che si deve scaricare PHP 5.0.4 zip package (o una versione più recente se disponibile). All'indirizzo postato dall'autore, ho scaricato la cartella 5.1.1 Win 32.zip.

Tale modulo può andare bene oppure no?

Intanto faccio anche la seconda domanda:

cos'altro serve per poter avere pagine in php, oltre il DB MySql?

Il PHPMyAdmin, serve scaricarlo adesso? Se si, potreste dirmi l'ind. x favore?

Grazie infinite...

Floyd

risposto 10 anni fa
floyd
X 0 X

PHP 5.1.1 andrà benissimo. Per il resto non ti serve altro. phpMyAdmin non è necessario in quanto è semplicemente una utility per amministrare MySQL.

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

grazie Gianni,

installerò prima il PHP 5.1 e poi faccio sapere il risultato.

Ho letto 1 pò in giro che il phpMyAdmin serve per amministrare MySQL;

l'ho chiesto, appunto, in previsione di installare il DB.

A proposito di  MySQL: che versione consigli di scaricare dal sito?

Grazie per la tua disponibilità.

Floyd

risposto 10 anni fa
floyd
X 0 X

per MySQL poi usare la 4.0 o la 4.1

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

ciao Gianni

eccomi qui...  :) manco a dirlo!

ho seguito tutti gli step per installare il php su IIS....

Premetto subito che il mio server non si trova su C:\ ma è contrassegnato con un'altra lettera.

Quando ho strovato scritto, nel tutorial, "C:\ ecc..." ho metto la lettera che contraddistingue la directory in cui si trova IIS.

quando vado a rikiamare: localhost/php.info  mi appare il seguente messaggio:

Non si è autorizzati a visualizzare questa pagina

HTTP 401.3 - Accesso negato dall'ACL sulla risorsa

Internet Information Services

Siccome la stessa cosa mi succede con i files .asp, appena messi nella directory,

sono andato con il pulsante dx del mouse sul file php.info ed ho assegnato i permessi in questo modo:

IUSR_nomemakkina e poi ho spuntato "modifica" >> OK >> ma mi viene ancora negato l'accesso.

Devo cambiare qualcosa nel file php.ini e mettere la lettera del mio HD al posto della C:\?

Non credo,  in quanto  ho già cambiato, come ho scritto + su.

Grazie

Floyd

risposto 10 anni fa
floyd
X 0 X

Purtroppo non usando IIS non so assolutamente come aiutarti. Non credo che ci sia altro da modificare ma penso sia solo una questione di permessi.  :dunno:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

scusate se riposto ancora;

ho rifatto tutti i passaggi (eliminato la cartella php dall'HD; scompattato la cartella zip ecc....; riletto tutto il tutorial ma alla fine mi appare sempre la scritta che "Non si è autorizzati a visualizzare questa pagina" ecc... Nesun amico/a ha avuto lo stesso problema? Come lo ha risolto?

Grazie 1000.

Floyd

risposto 10 anni fa
floyd
X 0 X

SIIIIIIIIII!!!

Mi appare la pagina di installazione del PHP 5.1!!!

Se qualche altro amico dovesse avere lo stesso problema, la cosa è molto semplice:

basta dare i permessi alla cartella php che si trova nella directory C:\;

selezionarla con il pulsante dx del mouse >> Protezione >>  e vedere se è presente l'utente IUSR_nomeMacchina;

se non c'è, premere il pulsante Aggiungi >> si apre una wizard e scrivere: IUSR_nomeMakkina >> premere OK e nella finestra successiva mettere la spunta su "modifica".

Rikiamare dal browser, in locale: http://localhost/nomepaginaprova.php.

Questa cosa va fatta per chi ha IIS.

Floyd

risposto 10 anni fa
floyd
X 0 X

Grande floyd  O0

questa cosa sarà sicuramente di aiuto per altri utenti PHP/IIS

Quindi i permessi vanno dati sia agli script che alla cartella di PHP?

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

ciao Gianni

spero possa servire agli altri amici del forum (se dovesse esserci il problema).

I permessi vanno dati al file (o ai files) php se, rikiamati nel browser,

appare la scritta che non si ha l'autorizzazione ecc...

se, anche con tale autorizzazione, appare ancora il messaggio,

li si deve dare alla cartella php contenuta nella root.

ciao

risposto 10 anni fa
floyd
X 0 X

ciao Gianni

e ciao a tutti gli amici

ho appena letto che è stata rilasciata la versione 5.1.2 di PHP, corretta e molto + stabile della precedente;

quello  che chiedo è: ogni volta che viene rilasciato un aggiornamento, si deve rifare tutta l'installazione, come è scritto nel tutorial?

Grazie

risposto 10 anni fa
floyd
X 0 X

In generale basta sostituire TUTTI i files con le versioni aggiornate. Bisogna comunque ricordarsi di configurare il php.ini come fatto nella prima installazione. Ad esempio per abilitare le estensioni mysql ecc.

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

Ciao al Moderatore

e ciao a tutti gli amici del forum;

Sono andato a ripescare le mie domande iniziali, per evitare di aprire altri post.

Ho appena installato l'estensione mysqli (ho letto il tutorial) e lanciando il file info.php, nel browser, appare la stessa schermata come quella dell'articolo. Dovrebbe essere tuto ok.

Adesso vorrei scaricare il DB MySql; siccome ho il PHP 5.1, quale versione mi conviene installare, del DB?

Grazie

Floyd

risposto 10 anni fa
floyd
X 0 X

Scusate ancora...

ho appena visitato il sito ufficiale di MySql, ed ho trovato scritto:

Windows downloads (platform notes):

Windows Essentials (x86)

Windows (x86)

Without installer (unzip in C:\)

e mi pare di aver capito che sarebbe consigliabile installare il 5.0.

Mi date conferma?

Grazie

Floyd

risposto 10 anni fa
floyd
X 0 X

Ci sono 3 versioni attualmente: 4.0, 4.1 e 5.0

La prima è quella più usata dai vari fornitori di hosting, quindi è da preferire se si vuole ricreare un ambiente simile a quello di un ipotetico server remoto.

La seconda ha qualche caratteristica in più, ha un installer più carino e si configura più facilmente. Alcuni server sono stati aggiornati a questa versione. Le ultime versioni di PHP 5 non necessitano di accorgimenti per poter funzionare con questa versione di MySQL. Con PHP 4 si possono avere dei problemi, soprattutto legati all'autenticazione.

MySQL 5 è il gioiellino, da usare per provare le nuove caratteristiche: stored procedures, triggers, viste, ecc.. Valgono le stesse indicazioni appena fatte per MySQL 4.1

Sia per MySQL 4.1 che per MySQL 5 converrebbe usare le funzioni dell'estensione mysqli al posto della vecchia mysql.

A te la scelta.  :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

php.info?

E che pagina è?

Io ai tempi (ora o linux con apache) su un win 2000 server+IIS per installare php ho seguito le istruzioni nel file di testo allegato a php. In inglese ma molto precise.

risposto 10 anni fa
LonelyWolf
X 0 X

Non so se opero correttamente. Ho installato PHP 5.1.4, Apache 2.2.2. e MySql 5.0.22 su di un pc con Xp sp2. il problema è che sembra tutto funzionare correttamente, ma quando eseguo la classica pagina di info, non mi compare la sessione che riguarda MySQL. Ovviamente ho già controllato in php.ini che la cartella con le extension sia ok e aggiunto sia la riga riguardante myslqi che tolto il punto e virgola da quella mysql, come da vostre indicazione nel tutorial......

Qualcuno sa aiutarmi?

Grazie

risposto 10 anni fa
morsandr
X 0 X

hai spostato il file libmysql.dll dalla cartella di PHP nella cartella di windows?

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

Certo, per sicurezza il file libmysql.dll l'ho messo sia in C:\windows che in c:\windows\system32, ma nulla nella pagina di test (info.php) non compare alcuna scritta riguardanet myslq o mysqli.

Andrea

risposto 10 anni fa
morsandr
X 0 X

alcuni tentativi:

1) installa Apache 2.0.x (ho avuto problemi con il 2.2)

2) controlla nella pagina generata dal phpinfo il percorso del file php.ini che attualmente viene usato e verifica che coincide con quello corretto.

3) abilita qualche altra estensione o fai qualche altra modifica al php.ini e verificane l'effetto

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda