Installazione apache php e mysql -> problemi :(

Ciao a tutti....

... ho trovato questo sito (e forum) alla ricerca di una soluzione per il problema... :idiot:

Sto istallando su un windows 2000 advanced server apache 2, php 5.1.1 e mysql server 5.0.

Ho visto la guida ed i problemi riportati nel forum da altre persone. :o ma non ho trovato la soluzione.

La situazione questa:

apache parte

php parte

ma il modulo mysql no

il problema sebra essere: da phpinfo vedo che il path per php.ini c:\winnt

anche se sul file di configurazione di apache ho inserito:

PHPIniDir "E:\Program Files\Php Module".

inoltre se sotto winnt non metto il php.ini .... non cambia nulla. anzi se tolgo tutti i php.ini (sia sotto winnt, sia sotto e:\program files\php module) ... non cambia nulla: continua a funzionare.

Grazie

inviato 10 anni fa
super_gulp
X 0 X

Il PHP non ha bisogno del php.ini per funzionare. Nel caso non riesca a trovarlo usa dei settaggi di default che possibile vedere attraverso il phpinfo()

Per prima cosa cercherei di capire perch la direttiva PHPIniDir inserita nel file httpd.conf non ha effetto. Verifica quindi questo passaggio. Fai attenzione alle estensioni nascoste dei files. Spesso windows non mostra le vere estensioni e si rischia di modificare i files sbagliati.

Fino a che php non trova il php.ini inutile cercare di abilitare l'estensione mysql

:bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

;D Stavo "postando" questo msg. quando ho visto la tua risposta (ti ringrazio)

Ma ora sembre funzionare tutto correttamente...

... ad un certo punto apache2 ha letto la direttiva del PHPIniDir e tutto (compreso il mysql) ha funzionato !!!

Grazie !!!!

O0

risposto 10 anni fa
super_gulp
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda