modificare pagina php del forum smf 1.1 rc2

ciao

houn forum smf dovrei modificare la pagina php , per mettere il alto un banner to tornare al home page del mio sito , qualcuno sa dirmi come posso fare?

come programma uso macromedia e di php so veramente poco ...

ciao :idiot:

inviato 10 anni fa
carlainz
X 0 X

dimmi più precisamente cosa vuoi inserire e dove.

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

allora vorrei fare una cosa simile come quella che e' qua su questo sito in alto , ma senza la barra arancione.

cioe solo il logo sulla sinistra col nome del mio sito dove la gente puo cliccare per tornare nel home page , e sulla destra propiop come qua gli annunci di google ....

ciao e grazie :bye: :bye:

risposto 10 anni fa
carlainz
X 0 X

Per prima cosa devi realizzare in HTML tutto il necessario per visualizzare logo e pubblicità. Potrebbe bastare una tabella con una riga e 2 colonne: nella primacolona metti il logo mentre nella seconda la pubblicità.

Fatto ciò devi modificare il file index.template.php che si trova nella cartella del tema che stai usando. I temi sono racclti nella cartella Themes di SMF. Se ad esempio stai usando il tema di default allora il file da modificare si troverà in Themes/default/index.template.php

Apri il file con un editor e cerca la riga che contiene "<body>", ovvero il tag che segna l'inizio del contenuto della pagina. A questo punto ti basta accodare al suddetto tag tutto l'HTML che hai realizzato in precedenza (quello per mostrare il logo) ed il gioco è fatto!

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

ciao :)

dopo il campo body ho incollato il codice html

</head>

<body>';

<table width="100%" border="1">

  <tr>

    <td width="400" height="140"><img src="file://///Pue/pri/logo.jpg" width="400" height="140" /></td>

    <td width="622">google</td>

  </tr>

</table>

</body>

</html>

   echo '

      <table cellspacing="0" cellpadding="0" border="0" width="100%">

ma quando apro il forum ho questo messaggio

Template Parse Error!

It seems something has gone sour on the forum with the template system. This problem should only be temporary, so please come back later and try again. If you continue to see this message, please contact the administrator.

You can also try refreshing this page.

dove sbaglio?

ciao e tante grazie :bye:

risposto 10 anni fa
carlainz
X 0 X

Prova così:

</head>

<body>

<table width="100%" border="1">

  <tr>

    <td width="400" height="140"><img src="file://Pue/pri/logo.jpg" width="400" height="140" /></td>

    <td width="622">google</td>

  </tr>

</table>';

   echo '

      <table cellspacing="0" cellpadding="0" border="0" width="100%">

P.S.: l'indirizzo dell'immagine è sbagliato!!! deve essere un normale URL. Così invece punta ad un file locale.

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

sono riuscito a mettere il logo in alto dove volevo ma se ci passo sopra il mouse non mi fa clikkare per tornare al home page

<body>

<table width="100%" border="0">

  <tr>

    <td width="286" height="100"><img src="http://82.x.x.x/logo.jpg" alt="Home Page" name="home page" width="286" height="100" start="mouseover" loop="-1" longdesc="http://82.x.x.x/index.html" /></td>

    <td width="622">google</td>

  </tr>

</table>';

   echo '

      <table cellspacing="0" cellpadding="0" border="0" width="100%">

dove sbaglio? grazie ancora :)

risposto 10 anni fa
carlainz
X 0 X

Devi mettere un tag <a> per creare un link. Mi sa che ti mancano le basi dell'HTML  :dunno:

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda