Problemi con installazione phpmyadmin

Ho installato senza problemi php5, apache2 e mysql4.1. Ho provato anche ad installare phpmyadmin 2.6.3 ma quando carico l'indirizzo http://localhost/phpmyadmin/index.php mi dà pagina bianca. :tichedoff:

Perché mai?

Grazie :bye:

inviato 10 anni fa
usecram
X 0 X

Fatti mostrare dal browser l'HTML della pagina e vedi se c'è scritto qualcosa che potrebbe fornire un indizio.

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

Già fatto nulla solo scheletro HTML, booo eppure le istruzioni le ho seguite. Che faccio reinstallo?

risposto 10 anni fa
usecram
X 0 X

prova ad usare il file di configurazione di phpMyAdmin "originale", ovvero senza modificarlo, e vedi se viene visualizzato qualcosa.

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

Fatto ecco il risultato:

Benvenuto in phpMyAdmin 2.6.3-pl1

phpMyAdmin ha provato a connettersi al server MySQL, e il server ha rifiutato la connessione. Si dovrebbe controllare il nome dell'host, l'username e la password nel file config.inc.php ed assicurarsi che corrispondano alle informazioni fornite dall'amministratore del server MySQL.

Suppongo che mi direte che ora devo reinserire il nome dell'host, l'username e la password del file config.inc.php. Giusto? Probabilmente avevo pasticciato qualcosa al primo tentativo. Vi tengo informati! ;)

risposto 10 anni fa
usecram
X 0 X

Duuunque avrei risolto perché phpmyadmin lo visualizzo correttamente  O0.

Però, giusto per non avere mai vita facile  :2funny:, leggo con preoccupazione questa segnalazione in index.php:

L'estensione PHP mbstring non è stata trovata e sembra che si stia utilizzando un set di caratteri multibyte. Senza l'estensione mbstring, phpMyAdmin non è in grado di dividere correttamente le stringhe di caratteri e questo può portare a risultati inaspettati.

Ma che è?

Grazie mille!

risposto 10 anni fa
usecram
X 0 X

Niente di grave, se n'è parlato già altre volte sul forum. Vai nel php.ini e abilita l'estensione mbstring.

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

Chiedo venia, effettivamente con una breve ricerca avrei saputo cosa devo fare.

risposto 10 anni fa
usecram
X 0 X

Ciao a tutti

sto seguendo alla letteraquesto  tutorial

http://www.phpnews.it/articoli/php/installare-apache-2-php-5-mysql-4.1-su-windows/2/

dove dice do aprire il file httpd di apache e inserire queste linee

LoadModule php5_module "c:/php/php5apache2.dll"

AddType application/x-httpd-php .php

PHPIniDir "C:/php"

ora mi chiedo dove prendo il php5apache2.dll visto che non esiste dentro la mia cartella php? e dove prendo il php5ts.dll che pure lui non esiste???

dove le prendo?

ho scaricato

apache_2.2.3-win32-x86-no_ssl.msi

php-5.2.0

mysql-essential-5.0.27-win32.msi

sono fermo in questa pagina del tutorial...

e con quelle linee nel httpd.conf di apache non riesco nemmeno ad avviarlo..

Grazie mille

risposto 10 anni fa
Rino
Rino
1
X 0 X

Siamo andati fuori tema...

risposto 10 anni fa
Gianni Tomasicchio
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda