installazione php/apache

Ciao a tutti, ho letto altri post ma nessuno ha dato una risposta.

ho fatto la procedura presente alla pagina: http://www.phpnews.it/content/view/67/80/1/2/

fino al punto che si deve riavviare apache. Ma a me non compare la finestra. Mi appare la schermata di DOS con all'interno la dicitura che non trova il file  "php5apache2.dll" mentre poi c'è! Perche' non parte apache? Grazie

il mio sito : www.basspower.it

inviato 10 anni fa
weiners
X 0 X

Hai aggiunto la riga:

LoadModule php5_module "c:/php/php5apache2.dll"

nel file httpd.conf e poi riavviato apache?

Se si, magari, non è

...."c:/php/php5apache2.dll"

ma

...."f:/php/php5apache2.dll"

perchè magari è una partizione con 'nome' diverso da "c:".

Prova a ricontrollare al link che hai postato se hai seguito correttamente le procedure di configurazione del file 'httpd.conf'

ciao

Lore

risposto 10 anni fa
Lore
Lore
1
X 0 X

Ciao, il percorso della cartella "php" e' giusto, si trova proprio in c:

il problema è che apache non parte proprio! Invece tu parli di riavviarlo....

il file di apache si trova in C:\Programmi\Apache Group\Apache\conf

e al file httpd.conf ho aggiunto la stringa

LoadModule php5_module "c:/php/php5apache2.dll"

AddType application/x-httpd-php .php

PHPIniDir "C:/php"

dopo loadmodule e dopo addmodule.....

salvo il file e clicco sull'icona di apache, ma mi esce sempre la schermata di DOS dove dice che non trova il file.

Il percorso è giusto pero' !

grazie!

risposto 10 anni fa
weiners
X 0 X

Che versione di apache hai scaricato?

Nella cartella c:/php/ c'è il file php5apache2.dll?

risposto 10 anni fa
Lore
Lore
1
X 0 X

ho installato questa versione: Win32 Binary (Self extracting): apache_1.3.34-win32-x86-no_src.exe

si, nella cartella c:/php c'è il file  php5apache2.dll

risposto 10 anni fa
weiners
X 0 X

ho installato questa versione: Win32 Binary (Self extracting): apache_1.3.34-win32-x86-no_src.exe

si, nella cartella c:/php c'è il file  php5apache2.dll

Tu stavi seguendo la guida

" Installare Apache 2, PHP 5, MySQL 4.1 su Windows "

ma non utilizzi apache2, bensì apache 1.3.34,

ci sono delle differenze nella configurazione tra quello che hai scariacto tu e apache2 (se non erro), solo che non me le ricordo a memoria quelle...

Se vuoi un consiglio, riaprti:

http://www.phpnews.it/content/view/67/80/

scaricando di volta in volta quello che ti viene suggerito, altrimenti prova a cercare le differenze tra le configurazione delle diverse versioni di apache...

ciao

Lore

risposto 10 anni fa
Lore
Lore
1
X 0 X

Ma all'indirizzo: http://httpd.apache.org/download.cgi apache 2.0 "puro" non c'è...

oppure tu lo vedi ed io so' imbranato :uglystupid:

risposto 10 anni fa
weiners
X 0 X

Ma all'indirizzo: http://httpd.apache.org/download.cgi apache 2.0 "puro" non c'è...

oppure tu lo vedi ed io so' imbranato :uglystupid:

Nella sezione:

" Apache HTTP Server 2.0.55 is also available "

c'è:

'Win32 Source: httpd-2.0.55-win32-src.zip [PGP] [MD5]'

dovrebbe andare bene quella,cmq segui tutte le istruzioni della guida  :D

ciao

Lore

risposto 10 anni fa
Lore
Lore
1
X 0 X

ok, ora disinstallo il vecchio e metto il nuovo. devo cancellare anche il file che ho copiato in c:/windows ?

provo col nuovo ed incrocio le dita...speriamo che funziona..

cmq ti ringrazio fin d'ora, sei stato molto gentile...

pero' se non funziona vengo la' e ti sparo.....se prima non mi so' sparato io!!  ;)

risposto 10 anni fa
weiners
X 0 X

ok, ora disinstallo il vecchio e metto il nuovo. devo cancellare anche il file che ho copiato in c:/windows ?

provo col nuovo ed incrocio le dita...speriamo che funziona..

cmq ti ringrazio fin d'ora, sei stato molto gentile...

pero' se non funziona vengo la' e ti sparo.....se prima non mi so' sparato io!!  ;)

Ho già avvisato  :police: della minaccia  O0

a parte gli skerzi, disinstalla la vecchia versione e poi segui passo passo la guida...

Ciao  :bye:

Lore

risposto 10 anni fa
Lore
Lore
1
X 0 X

Confermo che ci sono differenze nell'installazione di PHP su Apache 1.3.x e 2.0.x. Probabilmente sono la causa dell'errore che ti veniva mostrato.

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

a me sebra strano solo perche diceva che non trovava quel file...comunque sto scaricando la versione di apache piu' aggiornata 2.0.55 vi faro' sapere...

speriamo!

Devo cancellare anche qualcosa manualmente per non incorrere in conflitti con il vecchio apache?

risposto 10 anni fa
weiners
X 0 X

sto seguendo il passo passo spiegato in: http://www.phpnews.it/content/view/67/80/1/1/

e mi sono fermato qui: A conferma della corretta installazione, una nuova icona nel system tray ci informa dello stato del server Apache. Una freccia verde indica che Apache è in esecuzione sulla nostra macchina.

invece di uscire il tastino verde tipo "play" mi esce quello rosso tipo "stop"

why? :tichedoff: :tichedoff:

risposto 10 anni fa
weiners
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda