cartella scrivibile

Salve a tutti, ho installato apache,php e mysql su windows xp prof seguendo alla lettera le istruzioni riportate nell'articolo relativo trovato in questo sito, e tutto mi funziona alla perfezione. Il mio obbiettivo č provare vari CMS per poi sceglierne uno da utilizzare per un sito.

Ho installato quindi phpnuke in locale e funziona a meraviglia, ma con joomla (l'ultima versione in italiano) ho un problema che non riesco a risolvere: in pratica il software ha bisogno di una cartella scrivibile per la variabile session.save, quindi ho creato una cartella ad hoc, l'ho dichiarata nel php.ini ma il software mi dice che la cartella č abilitata ed esiste ma non č scrivibile. Quindi ho provato a rimuovere gli attributi di sola lettura in tutti i modi: ho attivato la condivisione ntfs di windows assognando tutti i permessi per le cartelle (ovviamente mi loggo come amministratore), ho provato a rimuovere l'attributo si sola lettura dalla finestra "proprietą", ma togliendo il segno di spunta, dopo aver chiuso e riaperto la finestra, esso torna al suo posto. Ho anche provato a  cambiarlo col comando "attrib" del dos, che mi restituisce "accesso negato". Purtroppo joomla non funziona se non risolvo questo problema...

Qualcuno sa aiutarmi? Ho postato anche in molti altri forum (compreso quello ufficiale del progetto joomla) e tra le risposte mi hanno detto che il problema potrebbe dipendere, oltre che da windows, dalla configurazione di apache.

Spero che qualcuno possa aiutarmi, grazie...

inviato 10 anni fa
Nornagest
modificato 10 anni fa
X 0 X

Ti riferisci alla cartella impostata da [tt]session.save_path[/tt]?

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

Si. Ho crato una cartella chiamata "tmp" all'interno di "htdocs" e l'ho definita nel php.in (č bastato inserire il percorso e togliere il segno di ;). Infatti la procedura di installazione di Joomla rileva che la cartella esiste ma mi dice che non č scrivibile...

 :wallbash:

risposto 10 anni fa
Nornagest
X 0 X

Prova ad usare la cartella C:\WINDOWS\Temp (Ricordati di riavviare Apache)

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

FUNZIONA!!!!!!!!!!

Grazie mille Gianni, adesso funziona tutto alla perfezione...

risposto 10 anni fa
Nornagest
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda