Problemi installazione Apache 2

Ciao a tutti/e !!!!!!!!!!!!!!!!!! :bye: :bye: :bye:

In primis complimentoni per l'articolo sull'installazione di php, sql e apache   O0

In secondis.... mi sono bloccato praticamente subito !!!!!!!    :uglystupid:

Dunque, ho installato Apache 2.0.59, alla fine dell'installazione Apache non ne vuole sapere di partire, dal Monitor di Apache il pulsante "start" č disattivato, e se provo a farlo partire dal menł di avvio mi dice che: "impossibile trovare il file specificato.. no installed service named "apache 2"....... why ?

inviato 10 anni fa
Frank
X 0 X

Ma cosa devi fare? se ti serve per provare i tuoi siti o i tuoi script in locale ti consiglio di scaricare e installare Xampp, č ottimo :)

risposto 10 anni fa
eXile
X 0 X

Vero, ma poi non impara ;)

prova ad andare in shell di comando (command su Win) e dare a mano i comandi apache

Segui questa semplice guida per la configurazione:

http://www.freebsd.org/doc/it_IT.ISO8859-15/books/handbook/network-apache.html

o questa:

http://www.latoserver.it/apache/

risposto 10 anni fa
Marco Grazia
X 0 X

Hai qualche altro server installato ed in ascolto sulla porta 80? (es. IIS, ma anche Skype)

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

Io ti consiglio Easyphp, comprende server Apache, MySQL, PHP e Phpmyadmin (ha anche un pannello per le estensioni del php), il tutto si avvia da automaticamente all'apertura del programma.

Puoi trovarlo in italiano qui.

 :bye:

risposto 10 anni fa
bonecrusher
X 0 X

Tra easyphp e xampp, molto meglio xampp.

E' aggiornato alle ultime versioni sia di php che apache e mysql. Cmq se vuole installarlo manualmente per imparare e tutta un'altra storia :)

risposto 10 anni fa
eXile
X 0 X

Grazie a tutti per le risposte che mi avete dato :), alla fine sono riuscito a risolvere il problema, era una pirlata :2funny:, IIS entrava in conflitto con Apache (prob erano entrambi in ascolto sulla stessa porta), ho sospeso IIS e installato exnovo Apache che ora funzica come un orologio svizzero O0.

risposto 10 anni fa
Frank
X 0 X

Ma disinstallalo IIS no?  :o

risposto 10 anni fa
Marco Grazia
X 0 X

Ciao a tutti, sono nuovo del forum e assolutamente inesperto di Apache, PHP, MySql...

Io uso WinXP Pro SP2 con IIS 5.1 e sviluppo solo in ASP. Da qualche tempo mi č venuta la sana curiositą di scoprire il fantastico mondo PHP e cosģ mi sono imbattuto su PHPnews.it. Ho seguito le istruzioni ma mi sono arenato subito...

Sul finale dell'installazione rimaneva aperta la finestra dos con questo messaggio:

Installing the apache2.2 service

The Apache2.2 service is successfully installed

Testing httpd.conf....

Errors reported here most be corrected before the service can be started.

httpd.exe: culd not reliably determine the server's fully qualified domain name,

using 192.168.1.20 for ServerName

(OS 10048)Di norma č consentito un solo utilizzo di ogni indirizzo di socket

(protocollo/indirizzo di rete/porta). :make_sock: could not bind to address o.o.o.o:00

no listening sockets available, shutting down

Unable to open logs

Note the errors message above, and press the <ESC> key to exit. 30..._

Dopo aver spulciato il forum senza trovare nulla che riportasse il problema che ho avuto io con Apache ho iniziato a rileggere tutti i post che contenessero "Apache" e ho provato a seguire i vari suggerimenti... finchč ho trovato questo 3reed e ho capito che il problema poteva essere IIS in ascolto sulla stessa porta di Apache!!!

Soluzione: anche io come Frank ho disattivato IIS, reinstallato Apache 2.2 et voilą! Ora 'Apache service monitor mi dice che Apache funziona! Se digito //localhost/ il browser mi rimanda IT Works!!!

Che spettacolo!

Grazie

Lo

risposto 8 anni fa
loreto
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda