Istallazione Apache - php

Salve a tutti, ho seguito l'articolo inerente l'istallazione del server apache e del rispettivo supporto php.sino a quando istallo solo il server apache funziona tutto, e la conferma la vedo dalla visualizzazione della pagina quando alla fine vado a digitare http://localhost.i problemi si presentano quando istallo la versione ultima di php. Non so per quale motivo ma quando seguo tutta la procedura cosi come e' postata e vado a riavviare il pannello di controllo di apache, apache mi dice che la richiesta e' fallita perche nn viene riconosciuto cio che bisogna inserire nel testo del file httpd.conf situato nella cartella confid di apache.il file nelllo specifico che nn viene letto,ma che e' situato pero fisicamente nella cartella php quando la estraggo sul computer all'indirizzo c:/php e' il seguente: php5apache2.dll. Questo file , nonostante l'indirizzo e' scritto giusto dal server apache nn viene letto e trovato....da che possono dipendere questi problemi? mi auguro di ricevere presto un vostro aiuto.Grazie stefano

inviato 10 anni fa
SteavenRome
X 0 X

Che versione di Apache hai installato? La 2.2? Se si, allora toglila e ripeti l'installazione con la 2.0

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

si ho istallato l'ultima versione che viene visualizzata sul sito.ora provo a seguire il tuo consiglio e ti faccio sapere in tempo reale se la situazione e' migliorata.grazie intanto

risposto 10 anni fa
SteavenRome
X 0 X

perfetto con la versione 2.0 funziona tutto alla grandissima...cmq toglimi iuna curiosita semrpe che tu possa levarmela:xche con la versione superiore di apache nn funge?dove sta i bug?oppure come deve essere la procedura di istallazione corretta?forse deve essere sviluppata in maniera diversa l'interazione tra apache e php.grazie in anticipo intanto

risposto 10 anni fa
SteavenRome
X 0 X

http://bugs.php.net/bug.php?id=37370&edit=1

non si tratta di un vero bug ma non esiste per il momento una soluzione con PHP 5.1.4

Apache 2.2 non riesce a collegarsi al modulo PHP poiché con questa nuova versione del server web la chiamata al modulo esterno è diversa. I due pezzi del puzzle non combaciano più.

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda