non riesco a far funzionare php 5 con apache 2

Uso una macchina con xp.

Ho installato Apache 2.0.52- tutto ok

ho installato php 5.1.6  utilizzando windows installer o roba simile.

Poi sono passato al collegamento tra i due pacchetti.

Collegamento tra php5 e Apache 2:

1. rinomino in c:\php il file php.ini-dist col nome php.ini e poi come secondo tentativo essendo andato a male il primo rinomino php.ini un altro file che si chiamava php.ini-e qualcosa di simile;

2.Ho  spostato nella cartella C:\windows il file php5apache2.dll che si trovava nella cartella C:\php

3.Quando vado a fare le modifiche standard nel  file httpd.conf e vado a inserire dopo l'ultimo load le tre righe come da specifica :

LoadModule php5_module "c:/php/php5apache2.dll"

AddType application/x-httpd-php .php

PHPIniDir "C:/php"

vedo che dopo avere memorizzato il file http.conf con le modifiche dette, Apache  non funziona piu'  e non riesco neanche a far funzionare php con quel piccolo script proposto nel forum (sempre stesso articolo).

Devo dire che per l'installazione di Apache ho lasciato le cartelle in cui è stato scompattato il file così come vengono proposte e quindi i nomi non sono esattamente quelli dell'articolo. Volevo installare mysql ma mi sono fermato qua.

Qualcuno mi sa dire come fare.

Grazie

Martino954

inviato 10 anni fa
martino954
X 0 X

Nella cartella C:\Windows dovevi mettere il file php5ts.dll e non il file php5apache2.dll che deve restare nella cartella di php

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

non dimenticare di modificare anche l´interno del php.ini :)

ciao

PS : controlla con l ´apposito tool che da apache che non siano presenti errori nel suo file di configurazione

risposto 10 anni fa
Andrea Turso
Andrea Turso
86
modificato 10 anni fa
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda

Domande simili