Apache in locale da errore

Gente ho letto la guida per installare apache e php e mi son bloccata.

Allora ho installato sia apache che php come riportato in questa guida

http://www.phpnews.it/articoli/php/installare-apache-2-php-5-mysql-4.1-su-windows/2/

ma al clik su Restart ecco come mi esche questo messaggio

Che devo fare? Chi mi aiuta?  :-\

inviato 10 anni fa
Des
Des
1
X 0 X

Son riuscita ma ora..

quando scrivi e salvo il file info.php

<?php 

phpinfo(); 

?>

e lo lancio http://localhost/info.php

Mi si vedono le scritte

<?php 

phpinfo(); 

?>

e non come nella foto della guida

 ???

risposto 10 anni fa
Des
Des
1
X 0 X

Significa che PHP non è installato correttamente in Apache.

Ricontrolla i passaggi uno ad uno.

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

Ok ora riprovo  ::) :-*

risposto 10 anni fa
Des
Des
1
X 0 X

Nulla ho controllato e ricontrollato  :-[

risposto 10 anni fa
Des
Des
1
X 0 X

riporta in ordine le operazioni che hai eseguito per installare PHP e le versioni dei vari programmi che stai utilizzando

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
modificato 10 anni fa
X 0 X

Allora

# Installazione di Apache

Ho scaricato apache_2.2.3-win32-x86-no_ssl come da guida e img e non ho avuto problemi al secondo tentativo. Poi sono andata come da tutorial in http://localhost/  e vedo solo la scritta in nero It works!

# Installazione di PHP

Ho scaricato php-5.2.0-Win32 zip. Dopo ho creato la cartella C:\php dove ho scompattato php-5.2.0-Win32.

Poi ho cercato il file di nome php5ts.dll nella cartella C:\php e spostato nella cartella di Windows C:\windows.

Fatto questo sono andata in  C:\Programmi\Apache Group\Apache2.2\conf   e ho cercato httpd.conf  che ho aperto con il bloc notes dove ho cercato le righe LoadModule e sotto a queste ho inserito

LoadModule php5_module "c:/php/php5apache2.dll" 

AddType application/x-httpd-php .php 

PHPIniDir "C:/php"

E salvato.

Dopo aver salvato il file httpd.conf sono andata in C:\php e ho rinominato il file php.ini-dist in php.ini

Ho cliccato sul pulsante Restart di apache e non mi ha dato nessun errore.

Ho aperto il blocco note e ho scritto le seguenti righe:

<?php 

phpinfo(); 

?> 

e l'ho salvato nella cartella htdocs di Apache con il nome di "info.php"

Allora ho digitato il seguente indirizzo: http://localhost/info.php ma mi fa vedere le scritte citate qua sopra cioè

<?php 

phpinfo(); 

?>

come le si guardano in un normale bloc notes.

 :-\ :-\ :-\

risposto 10 anni fa
Des
Des
1
X 0 X

nella cartella di PHP c'è forse un file con un nome simile (ma non uguale) a php5apache2.dll ?

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

Si  :-\ e c'è anche php5apache2_2.dll oltre a php5apache2.dll

risposto 10 anni fa
Des
Des
1
X 0 X

allora cambia

LoadModule php5_module "c:/php/php5apache2.dll"

in

LoadModule php5_module "c:/php/php5apache2_2.dll"

e fammi sapere.

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

Ho provato ma non va  :'(

:knuppel: prima o poi userò le maniere non buone  :tichedoff:

risposto 10 anni fa
Des
Des
1
X 0 X

Bestiale se faccio http://localhost/info.php?var=12  vedo le info come da guida e img  :o

risposto 10 anni fa
Des
Des
1
X 0 X

mi sono perso, l'indirizzo

http://localhost/info.php

non va metre questo si:

http://localhost/info.php?var=12

 :o ? ? ? ?

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

esatto  :o :buck: ??? :-\

risposto 10 anni fa
Des
Des
1
X 0 X

Toglimi una curiosità: come ti è venuto di mettere var=12 ?

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

Da un sito che dice

Configurazione di Apache Web Server.

Per informazioni più dettagliate sullinstallazione di Apache controlla questa pagina: Installazione di Apache 2.

Una volta installato Apache (supponiamo in C:\Programmi\Apache Group\Apache2\):

    * Aprite il file C:\Programmi\Apache Group\Apache2\conf\httpd.conf e aggiungete nella sezione Dynamic Shared Object (DSO) Support un rigo contenente:

   1.

      LoadModule php5_module C:/Programmi/php/php5apache2.dll

Notate le barre rigirate!

Questo modulo che viene caricato da Apache allavvio, ed è quindi più veloce rispetto alla modalità CGI (che deve avviare il programma php.exe ogni volta).

    * Per usare PHP come filtro inserite in httpd.conf (più in basso in httpd.conf ci sono dichiarazioni analoghe) la seguente riga:

   1.

      AddType application/x-httpd-php .php

    * Riavviate Apache dalApache Monitor vicino allorologio o dal menu.

    * Ora Apache è pronto ad interpretare i files .php, fate una rapida prova creando un file C:\Programmi\Apache Group\Apache2\htdocs\prova.php contenente:

   1.

      <?php phpinfo(); ?>

poi dal vostro browser andate alla pagina http://localhost/prova.php (oppure alla porta 8080), se appare una lunga pagina con un bel po di informazioni sul vostro PHP, allora avete finito! (localhost o 127.0.0.1 sono rispettivamente il nome e lindirizzo IP con cui la vostra macchina identifica se stessa)

Vi ricordo che dalla versione 4.1 di PHP le variabili ricevute con GET e POST non sono più globali.

Cioè se chiamate http://localhost/prova.php?var=12 (8080), non avrete una variabile $var con valore 12, ma avrete una voce var nel dizionario _REQUEST (scorrete fino in fondo alla pagina per vederlo).

Per maggiori informazioni su questo cambiamento leggete qua: Release notes PHP 4.1.

risposto 10 anni fa
Des
Des
1
X 0 X

si ma si riferisce a tutt'altra questione

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

Sto reinstallando tutto da capo e al completamente della parte di apache finalmente leggo

Funziona! Il Server Web Apache è stato installato su questo sito Web!

Come da guida e img  :angel:

Ora vedo di continuare  ::)

risposto 10 anni fa
Des
Des
1
X 0 X

Questa volta è tutto filato liscio.

Ora per testare un cms in locale come lo lancio?

Devo estrarre il contenuto cms nella cartella htdocs?

Creare una cartella del cms in htdocs e poi?

risposto 10 anni fa
Des
Des
1
X 0 X

Come non detto son riuscita a installare per la prima volta in locale un cms  :clapping:

Si festeggia.. vi offro da bere  ;D

risposto 10 anni fa
Des
Des
1
X 0 X

 :clapping:

:bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

 8) mo inizio a smanettare..e rompere i @@ a voi  ;D mo so azzi  :2funny:

risposto 10 anni fa
Des
Des
1
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda