down colossale

ragazzi oggi phpnews.it ha vissuto ben 8 ore di down  :'( dalle 13 ( più o meno ) a pochi minuti fà infatti il sito è stato inaccessibile per me ed altri utenti.

La home portava ad un url del tipo phpnews.it/installation/ e poi dava errore 404 ma anche cercando di intervenire sull'url per accedere all'indice si veniva reindirizzati a questo url.

Gianni come mai è successo questo?  :o

 O0 non fa nulla, resteremo fedeli a vita a questo sito  :smitten:

 :bye:

inviato 9 anni fa
Andrea Turso
Andrea Turso
86
X 0 X

segnalo incompatibilita' con i caratteri accentati, il charset della pagina ( il forum ) è UTF-8 ( almeno io vedo cosi' ) e i caratteri accentati vengono sostituiti da punti interrogativi ( ? )

:bye:

risposto 9 anni fa
Andrea Turso
Andrea Turso
86
X 0 X

Preferisco non commentare l'accaduto, sia perché la dinamica non mi è del tutto chiara, sia perché tempo sia colpa mia  :lamo:

Il problema dei caratteri dovrebbe essere stato corretto, anche se i post scritti durante il ripristino del forum potrebbero rimanere coi caratteri sballati.

Se riscontrate altri problemi fatemi sapere.

 :bye:

risposto 9 anni fa
Gianni Tomasicchio
X 0 X

non ti preoccupare Gianni, il mio post non era certo un rimprovero per l'accaduto  :tichedoff:

non importa cosa sia successo, errare è umano, incolpare gli altri è divino, no? :smitten:

io sono molto affezzionato a questo sito e questo forum, non fa nulla se è stato down un pò, l'importante che ora siamo qui a parlare  ;)

non era assolutamente un rimprovero  ???

 :bye:

risposto 9 anni fa
Andrea Turso
Andrea Turso
86
X 0 X

Non fa niente capita di sbagliare...per rimediare all'accaduto potresti metterti a modificare uno per uno tutti i post dove ci sono i caratteri nn conformi alla codifica  e sostituirli con quelli giusti...ihihiihihihih ;D ;D...

a parte gli scherzi nn è successo nulla dai il portale è ancora in piedi quindi... :D  :angel: :coolsmiley: :P

risposto 9 anni fa
mat
mat
1
X 0 X

il problema vero è che non ho ancora capito nel dettaglio la dinamica dell'accaduto. Si è trattato comunque di simpatici crackers.

 :police:

risposto 9 anni fa
Gianni Tomasicchio
X 0 X

ma hanno operato sul nostro portale o a livello di server!?  :-\

risposto 9 anni fa
mat
mat
1
X 0 X

il regalino è stato squisitamente personale...

risposto 9 anni fa
Gianni Tomasicchio
X 0 X

Cioè fammi capire Gianni... C'è stato un attacco da parte di qualcuno?

risposto 9 anni fa
Marco Dario
X 0 X
Cioè fammi capire Gianni... C'è stato un attacco da parte di qualcuno?

esatto, ma più che un "qualcuno" è stato un "qualcosa". Suppongo che si tratti di sistemi automatici che spazzolano interi range di IP alla ricerca di script con vulnerabilità note.

Il mio errore è stato quello di usare uno script per le statistiche (noto per i problemi di sicurezza) e di lasciare il register global ad ON (per compatibilità con un componente di Joomla).

Ora lo script delle statistiche è passato a miglior vita, metre ho corretto il componente Joomla per farlo funzionare con il register global ad OFF.

Speriamo che basti.

 :bye:

risposto 9 anni fa
Gianni Tomasicchio
X 0 X

A questo punto dovresti fare due cose, segnalare qual'è lo script di statistica incriminato così che altri che magari lo utilizzassero potrebbero evitare di usarlo o avvisare chi o produce del grave errore incorso.

E segnalare alla comunità di Joomla! come si modifica il loro script. In passato proprio per le colpe di una vecchia versione di Joomla! ne ho passati di guai.

Ah se hai l'exploit magari passamelo in messaggio privato, così vediamo se si può ricondurre a qualche IP noto ;)

risposto 9 anni fa
Marco Grazia
X 0 X

Lo script in questione è phpstats. Già in passato erano stati individuati (e risolti) problemi di sicurezza ma purtroppo lo sviluppo di tale programma è ormai fermo e quindi non è da considerare affidabile.

Comunque sto attribuendo la colpa a phpstats solo per esclusione, perché confido in Joomla e SMF, che aggiorno puntualmente con le ultime versioni.

Su Joomla utilizzo il componente ako_comment, pesantemente modificato però, in modo da aggiungere il controllo capcha ed altre cosette. La versione attuale di ako_comment dovrebbe funzionare con il register global ad OFF ma quella dalla quale sono partito invece era legata a tale impostazione di configurazione.

 :bye:

risposto 9 anni fa
Gianni Tomasicchio
X 0 X

Perfetto.

In effetti phpstats mi ha deluso parecchio, ci sono evidenti bug inoltre la loro licenza è strana, dato che non ti permette di usarlo per scopi commerciali, ma non dice nulla per questi ultimi: http://www.phpstats.net/?Licenza

ovvero dice solo che non si può usare, ma è una negazione tut court, non c'è modo di usarlo altrimenti nemmeno pagando.

Comunque a parte ciò sembra fermo da un anno, avevo trovato un altro ottimo sistema di statistica free, ma non ricordo più il nome  ???

Sui componenti di Joomla! non mi pronuncio dato che non lo uso, ma so che c'era la lista nera dei componenti, ma ora è stata tolta.

risposto 9 anni fa
Marco Grazia
X 0 X

Per le statistiche io uso awstats (è a questo che ti riferivi marcolino?) oppure google analytics

risposto 9 anni fa
Xscratch
X 0 X

Bho forse, guarda ho un vuoto totale.

A proposito http://www.nwi.it/showPage.php?template=approfondimenti&id=6833

risposto 9 anni fa
Marco Grazia
X 0 X

eh...quello l'ho capito...però 28-02-2005

risposto 9 anni fa
Xscratch
X 0 X
eh...quello l'ho capito...però 28-02-2005

Sì avevo letto la data, ma fino a quando non so se il bug è stato risolto, io non mi fido ;)

risposto 9 anni fa
Marco Grazia
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda