Autenticazione

Ciao

Avevo depositato tempo fa su un server remoto uno script funzionante sullautenticazione utente che si avvale dei soliti $PHP_AUTH_USER e $PHP_AUTH_PW  e dell header per inserire il login.

Dopo aver cambiato server questo script non funziona più. Non funziona nemmeno in locale, a meno di non settare il Global_registers = On. (pratica che sembra non essere più apprezzata, e se qualcuno mi suggerisce un nuovo sistema in uso mi fa piacere)

Ma allora anche sul server deve essere settato il php.ini? Se fosse cosi da dove viene preso?

?????

Paolo

inviato 9 anni fa
antares
X 0 X

cercale nella variabile $_SERVER  :bye:

risposto 9 anni fa
Xscratch
X 0 X
cercale nella variabile $_SERVER  :bye:

Esatto, per l'esatezza: $_SERVER['PHP_AUTH_USER'] per altre info guarda qui

 :bye:

risposto 9 anni fa
Marco Dario
X 0 X

Ciao di nuovo Mave, grazie anche a te Xscratch (perchè non scrivete i nomi grrrrrr  :P )

 :) :)

Scusate ma non capisco il senso della lettura che mi avete suggerito (che poi è quella del manuale ufficiale PHP).

O forse ho frainteso e devo leggere qualcosa in particolare ?

Lo script di autenticazione è gia' realizzato con i criteri dello scritto del manuale, ma non funziona in locale solo a causa del globals_register (altrimenti è ok) e non funziona sul server, e non ne so la causa che è quello che volevo sapere.

Paolo

risposto 9 anni fa
antares
X 0 X

In quello script vengono utilizzate correttamente le nuove variabili $_SERVER['PHP_AUTH_USER'] e $_SERVER['PHP_AUTH_PW']. Tutto qui.

 :bye:

risposto 9 anni fa
Gianni Tomasicchio
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda