Problema auto-increment

ciao ragazzi

Ho un problema: se tento di inserire un record nella mia tabella con phpmyadmin mi da unerrore.

In pratica ho il campo id (primaria, auto-increment) e poi tutti gli altri.

Di solito... cliccavo su inserisci riga.. mettevo i miei dati e il campo id appunto, l' ho sempre lasciato vuoto...tanto si incrementa da solo..invece se non metto io un numero nel campo id guardate che errore mi esce.

Se riuscite a darmi una soluzione vi son grato.

Ecco l'errore

Database gallovip - tabella donne in esecuzione su localhost

Errore

query SQL :

INSERT INTO `donne` (`id`, `nome`, `immagine`, `luogo_nascita`, `data_nascita`, `nazione`, `professione`, `n_immagini`, `n_video`, `n_calendari`, `n_wallpapers`, `n_screensaver`, `n_video_tv`, `n_video_backstage`, `n_video_scoop`, `n_video_film`, `n_video_altri`, `n_foto_scoop`, `n_foto_servizi`, `n_foto_tv`, `n_foto_altre`, `segnalato_da`, `n_commenti`, `voti`, `votanti`, `ult_aggiornamento`, `ult_materiale`, `click_giorno`) VALUES ('', '', '', 'Sconosciuto', 'Sconosciuta', 'Sconosciuta', '', '0', '0', '0', '0', '0', '0', '0', '0', '0', '0', '0', '0', '0', '0', '', '0', '0', '0', '0', '', '0');

Messaggio di MySQL:

Incorrect integer value: '' for column 'id' at row 1

inviato 9 anni fa
pazzomania
X 0 X

Che versione di MySQL e phpMyAdmin stai usando? Se MySQL recente mentre phpMyAdmin datato allora la cosa potrebbe essere spiegabile. In tal caso prova a mettere NULL nel campo autoincrement e vedi se viene inserito automaticamente il successivo intero.

:bye:

risposto 9 anni fa
Gianni Tomasicchio
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda