sfoglia le opzioni straniere

ciao a tutti,

da alcuni gg ho un problema sulla linea WAMP del server (qui sotto descritta alla firma), non riesco a far comparire in fase di data entry, a fianco di un campo l'elenco a discesa che dovrebbe avere :wallbash:. Questo campo fa riferimento ad una tabella importata come file CSV, se svuoto questa tabella il collegamento funziona, se inserisco dei record manualmente anche, ma non funziona se importo i dati come detto.

ho anche fatto una prova su un'altro PC con versioni meno recenti e tutto funziona, anzi, essendo lungo l'elenco si attiva l'opzione "sfoglia le opzioni straniere" per chi ha phpmyadmin in inglese compare "browse foreign values".

Qualcuno saprebbe aiutarmi, grazie  :bye:

inviato 9 anni fa
guido
X 0 X

ciao a tutti,

mi rispondo dando alcune info che spero possano servire anche ad altri: ho aggiornato le versioni di php, mysql e pma come specificato alla firma, per mysql sia la community-nt e sia la client sono la 5.0.45.

ho importato i db e le relazioni fra tabelle sono state mantenute, come pure gli elenchi a discesa creati precedentemente, con la 2.11 di pma adesso è possibile fare anche le viste  O0

Mi rimane però il problema, cioè gli elenchi a discesa non compaiono in tabelle dove il collegamento si riferisce ad una tabella importata come file CSV, se in quest'ultima cancello tutti i record e ne inserisco alcuni manualmente, l'elenco a discesa nella tab. collegata compare  :-\

Qualcuno potrebbe aiutarmi, grazie  :bye:

risposto 9 anni fa
guido
X 0 X

Senza un messaggio di errore è difficile capire quale sia la causa, quindi ti consiglio di mettere la direttiva ERROR_REPORTING al valore ALL, operazione che puoi fare sia da php.ini sia in testa al primo script PHP richiamato.

 :bye:

risposto 9 anni fa
Gianni Tomasicchio
X 0 X

Problema risolto la causa, internet explorer 7 installato sul server ed utilizzato da uno specifico account in dominio. Se mi collego a phpmyadmin con qualsiasi altro account (remote desktop) il problema non sussiste, non sussiste neanche se mi collego da altro pc

Grazie cmq delle info Gianni  :bye:

risposto 9 anni fa
guido
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda