Errore phpmyadmin

Ebbene dopo aver installato Apache 2.2.6, PHP 5.2.4 e MySQL 5.0.45 arriva il sacrosanto momento di installare pure phpmyadmin (2.11.1). Credo di aver seguito correttamente quanto descritto nella vostra guide nella configurazione, per quando vado su http://localhost/phpmyadmin/index.php spunta fuori il seguente errore:

Warning: phpMyAdmin-ERROR: cannot open themes folder: in C:\Programmi\Apache Software Foundation\Apache2.2\htdocs\phpmyadmin\libraries\Theme_Manager.class.php on line 269

Warning: Cannot modify header information - headers already sent by (output started at C:\Programmi\Apache Software Foundation\Apache2.2\htdocs\phpmyadmin\libraries\Theme_Manager.class.php:269) in C:\Programmi\Apache Software Foundation\Apache2.2\htdocs\phpmyadmin\libraries\core.lib.php on line 605

Warning: Cannot modify header information - headers already sent by (output started at C:\Programmi\Apache Software Foundation\Apache2.2\htdocs\phpmyadmin\libraries\Theme_Manager.class.php:269) in C:\Programmi\Apache Software Foundation\Apache2.2\htdocs\phpmyadmin\libraries\core.lib.php on line 605

Warning: Cannot modify header information - headers already sent by (output started at C:\Programmi\Apache Software Foundation\Apache2.2\htdocs\phpmyadmin\libraries\Theme_Manager.class.php:269) in C:\Programmi\Apache Software Foundation\Apache2.2\htdocs\phpmyadmin\libraries\core.lib.php on line 605

Warning: Cannot modify header information - headers already sent by (output started at C:\Programmi\Apache Software Foundation\Apache2.2\htdocs\phpmyadmin\libraries\Theme_Manager.class.php:269) in C:\Programmi\Apache Software Foundation\Apache2.2\htdocs\phpmyadmin\libraries\core.lib.php on line 605

Warning: Cannot modify header information - headers already sent by (output started at C:\Programmi\Apache Software Foundation\Apache2.2\htdocs\phpmyadmin\libraries\Theme_Manager.class.php:269) in C:\Programmi\Apache Software Foundation\Apache2.2\htdocs\phpmyadmin\index.php on line 99

Spero che ancora qualcuno sia in grado di aiutarmi _.

inviato 9 anni fa
Hybrid
X 0 X

il primo errore quello che conta: "cannot open themes folder"

sembra che la cartella di phpmyadmin contenente i temi (la veste grafica) non sia accessibile. Tu questa cartella la vedi? Hai modificato qualcosa nel file di configurazione di phpmyadmin relativo al percorso delle catelle?

risposto 9 anni fa
Gianni Tomasicchio
X 0 X

S, la cartella phpmyadmin\themes la vedo e non ho modificato nulla oltre a quanto descritto nella guida, vale a dire:

  • $cfg['Servers'][$i]['host']
  • $cfg['Servers'][$i]['connect_type']
  • $cfg['Servers'][$i]['auth_type']

Questo dovrebbe essere tutto ci che ho modificato nel file di configurazione

risposto 9 anni fa
Hybrid
X 0 X

Nel file di configurazione ci dovrebbe essere una direttiva che indica il percorso assoluto della cartella principale di phpmyadmin. Prova ad impostarlo.

:bye:

risposto 9 anni fa
Gianni Tomasicchio
X 0 X

Dovrebbe essere questo, correttamente impostato:

* @global string $cfg['PmaAbsoluteUri']
*/
$cfg['PmaAbsoluteUri'] = 'http://localhost/phpmyadmin/';

Inoltre anche il (o la?) path per la cartella dei temi giusta:

* @global string $cfg['ThemePath']
*/
$cfg['ThemePath'] = './themes';

Dove potrebbe essere l'errore _?

risposto 9 anni fa
Hybrid
X 0 X

non mi viene niente in mente... perch non provi a reinstallarlo da zero?

risposto 9 anni fa
Gianni Tomasicchio
X 0 X

Niente ho provato ad installare pure la versione 2.10.3 ma mi da comunque errore:

Warning: Percorso per il tema non trovato ! in C:\Programmi\Apache Software Foundation\Apache2.2\htdocs\phpMyAdmin\libraries\Theme_Manager.class.php on line 228

Fatal error: Call to a member function getName() on a non-object in C:\Programmi\Apache Software Foundation\Apache2.2\htdocs\phpMyAdmin\libraries\common.lib.php on line 3046

Che altro si pu fare? Gianni, se magari riesci a passarmi un file config corretto, che non sia quello a creare problemi

in locale, quindi lURL per phpmyadmin http://localhost/phpmyadmin/.

A questo punto mi viene spontanea la disperazione _.

risposto 9 anni fa
Hybrid
X 0 X

Come installi phpmyadmin? Che modifiche fai al file di configurazione?

:bye:

risposto 9 anni fa
Gianni Tomasicchio
X 0 X

Come detto prima, faccio solamente ci che descritto nella guida. Nulla di pi o meno, sono abbastanza sicuro di configurare il tutto correttamente.

Tuttavia non ha pi importanza, adesso mi sono installato Apache2Triad, spero di aver fatto una valida scelta.

Ti ringrazio comunque moltissimo per lattenzione e il tempo che mi hai dedicato =).

risposto 9 anni fa
Hybrid
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda