phpMyAdmin strano problema

Ciao a tutti,

ho un problema con phpMyAdmin nel senso che se accedo alla sua pagina index.php mi dà questi errori:

[tt]Errore

Messaggio di MySQL: 

#2003 - Can't connect to MySQL server on 'localhost' (10061)[/tt]

e

[tt]Impossibile caricare l'estensione mysql,<br />prego controllare la configurazione di PHP - Documentazione[/tt]

Ora, la cosa strana è che se invece accedo a main.php, tutta la application funziona, riesco a creare tabelle ecc. Inoltre con miei script php riesco ad interfacciarmi a MySQL e a passare query.

Questo significa che:

-mysql funziona ed il servizio è attivo

-il firewall non blocca la porta 3306 (che cmq per sicurezza ho aperto) visto che mysql risponde

-php carica il modulo relativo a mysql, come specificato nel php.ini, altrimenti non potrebbe funzionare

-il config.inc.php di phpMyAdmin è configurato giusto

In pratica l'unica cosa che non và è la pagina iniziale index.php, però ho notato che lanciando main.php alla fine ritorna a index.php passandogli un parametro chiamato token con una stringa lunga (tipo cookie), e in quel modo funziona.

Qualcuno mi sa aiutare?

Grazie in anticipo,

Daniele

inviato 10 anni fa
manerg
X 0 X

Prova a scaricare l'ultima versione di phpmyadmin e riconfiguralo da zero.

 :bye:

risposto 10 anni fa
Gianni Tomasicchio
X 0 X

E' già l'ultima versione, cmq credo di aver capito il problema, ed ho risolto.

Probabilmente la configurazione automatica che ho usato non è andata a buon fine, e da lì in poi era inutile ciò che facevo nel config.inc.php (parlo ovviamente della sola pagina index.php). 

Se può interessare consiglio quindi di copiare il file "config.default.php" dalla directory "libraries" nella directory principale di phpMyAdmin, rinominarlo in "config.inc.php", ed editarlo manualmente. Così tutto dovrebbe funzionare.

 :coolsmiley:

ciao, a presto

risposto 10 anni fa
manerg
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda