pulsanti bbcode

salve ragazzi volevo chiedervi dovrei fare i pulsantiper il bbcode adesso ho fatto cosi pero non riesco a capire il motivo perchenon funziona echo"<input type='button' value='b' class='buttonbbcode' style='font-weight:bold;width:25px;' onClick=\"addText('testo_auto', '[b]', '[/b]');\"> <input type='button' value='i' class='buttonbbcode' style='font-style:italic;width:25px;' onClick=\"addText('testo_auto', '[i]', '[/i]');\"> <input type='button' value='u' class='buttonbbcode' style='text-decoration:underline;width:25px;' onClick=\"addText('testo_auto', '[u]', '[/u]');\"> <input type='button' value='url' class='buttonbbcode' style='width:30px;' onClick=\"addText('testo_auto', '[url=http://', ']', '[/url]');\"> <input type='button' value='mail' class='buttonbbcode' style='width:35px;' onClick=\"addText('testo_auto', '[mail]', '[/mail]');\"> <input type='button' value='img' class='buttonbbcode' style='width:30px;' onClick=\"addText('testo_auto', '[img]http://', '[/img]');\"> <input type='button' value='left' class='buttonbbcode' style='width:45px;' onClick=\"addText('testo_auto', '[left]', '[/left]');\"> <input type='button' value='center' class='buttonbbcode' style='width:45px;' onClick=\"addText('testo_auto', '[center]', '[/center]');\"> <input type='button' value='right' class='buttonbbcode' style='width:45px;' onClick=\"addText('testo_auto', '[right]', '[/right]');\"> <input type='button' value='small' class='buttonbbcode' style='width:40px;' onClick=\"addText('testo_auto', '[small]', '[/small]');\"> <input type='button' value='code' class='buttonbbcode' style='width:40px;' onClick=\"addText('testo_auto', '[code]', '[/code]');\"> <input type='button' value='quote' class='buttonbbcode' style='width:45px;' onClick=\"addText('testo_auto', '[quote]', '[/quote]');\">";dove sbaglio? e se volessi inserire delle immagini come potrei fare grazie

inviato 8 anni fa
roccochiolo
X 0 X

scusate ancora ho trovato questo script il primo va nella parte dove deve essere la barra del bbcode bbcodeToolbar('submitticket','testo_auto');

il secondo lo richiamo tramite require_once pero non funziona

function bbcodeToolbar($form,$element,$style="public") {
$content = "";

switch ($style) {

case "public":
$content .= "<img src='../immagini/bbcode/bold.gif' style='margin:1px;' title='Bold' onclick=\"addBBCode('testo_auto', '[b]', '[/b]');\">";
$content .= "<img src='../immagini/bbcode/italic.gif' style='margin:1px;' title='Italic' onclick=\"addBBCode('testo_auto', '[i]', '[/i]');\">";
$content .= "<img src='../immagini/bbcode/underline.gif' style='margin:1px;' title='Underline' onclick=\"addBBCode('testo_auto', '[u]', '[/u]');\">";
$content .= "<img src='../immagini/bbcode/color.gif' style='margin:1px;' title='Fontcolor' onclick=\"addBBCodeColor('testo_auto', '[color]', '[/color]')\">";
$content .= "<img src='../immagini/bbcode/spacer.gif' style='margin:0px;'>";
$content .= "<img src='../immagini/bbcode/left.gif' style='margin:1px;' title='Left' onclick=\"addBBCode('testo_auto', '[left]', '[/left]');\">";
$content .= "<img src='../immagini/bbcode/center.gif' style='margin:1px;' title='Center' onclick=\"addBBCode('testo_auto', '[center]', '[/center]');\">";
$content .= "<img src='../immagini/bbcode/right.gif' style='margin:1px;' title='"._RIGHT_."' onclick=\"addBBCode('testo_auto', '[right]', '[/right]');\">";
$content .= "<img src='../immagini/bbcode/spacer.gif' style='margin:1px;'>";
$content .= "<img src='../immagini/bbcode/img.gif' style='margin:1px;' title='"._IMAGE_."' onclick=\"addBBCode('testo_auto', '[img]http://', '[/img]');\">";
$content .= "<img src='../immagini/bbcode/flash.gif' style='margin:1px;' title='"._FLASH_."' onclick=\"addBBCodeFlash('flash','$form','$element');\">";
$content .= "<img src='../immagini/bbcode/youtube.gif' style='margin:1px;' title='YouTube' onclick=\"addBBCodeYouTube('youtube','$form','$element');\">";
$content .= "<img src='../immagini/bbcode/spacer.gif' style='margin:1px;'>";
$content .= "<img src='../immagini/bbcode/url.gif' style='margin:1px;' title='"._URL_."' onclick=\"addBBCodeUrl('url','$form','$element');\">";
$content .= "<img src='../immagini/bbcode/email_link.gif' style='margin:1px;' title='"._EMAIL_."' onclick=\"addBBCode('testo_auto', '[mail]', '[/mail]');\">";
$content .= "<img src='../immagini/bbcode/spacer.gif' style='margin:1px;'>";
$content .= "<img src='../immagini/bbcode/quote.gif' style='margin:1px;' title='"._QUOTE_."' onclick=\"addBBCode('testo_auto', '[quote]', '[/quote]');\">";
$content .= "<img src='../immagini/bbcode/code.gif' style='margin:1px;' title='"._CODE_."' onclick=\"addBBCode('testo_auto', '[code]', '[/code]');\">";
break;
}

echo $content;
}

cosa potrebbe essere il problema a questa e la texarea

<textarea name='testo_auto' rows='6' class='messtextare' id='testo_auto'></textarea>
risposto 8 anni fa
roccochiolo
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda