PEAR - Spreadsheet Excel Writer

Ciao a tutti,

vorrei imparare a generare in automatico fogli excel.

Ho visto che il modo migliore usare le librerie PEAR (giusto?) ed ho scaricato il Spreadsheet_Excel_Writer-0.91.

Dopo averlo scompattato fatto girare ho constatato che tra i vari require_once nel file Workbook.php ci sono anche questi due:

OLE/PPS/Root.php alla riga 39

OLE/PPS/File.php alla riga 40

Visto che nel file zip non ci sono dove li vado a reperire?

il codice che sto usando quello scaricato dal sito pear.php.net :

<?php
require_once 'Writer.php';

// Creating a workbook
$workbook = new Spreadsheet_Excel_Writer();

// sending HTTP headers
$workbook->send('test.xls');

// Creating a worksheet
$worksheet =& $workbook->addWorksheet('My first worksheet');

// The actual data
$worksheet->write(0, 0, 'Name');
$worksheet->write(0, 1, 'Age');
$worksheet->write(1, 0, 'John Smith');
$worksheet->write(1, 1, 30);
$worksheet->write(2, 0, 'Johann Schmidt');
$worksheet->write(2, 1, 31);
$worksheet->write(3, 0, 'Juan Herrera');
$worksheet->write(3, 1, 32);

// Let's send the file
$workbook->close();
?>

Se aveste altre soluzioni o tutorial per raggiungere lo scopo sono le ben venute.

Grazie in anticipo,

PURAVIDA

inviato 8 anni fa
puravida
X 0 X

Tempo f ho usato quel package, seguendo questa guida:

http://www.sitepoint.com/article/pear-spreadsheet_excel_writer

L'unico require presente nell'esempio questo

require_once "Spreadsheet/Excel/Writer.php";

:bye:

risposto 8 anni fa
Gianni Tomasicchio
X 0 X

Ciao Gianni,

se apri il file "Spreadsheet/Excel/Writer.php" ti accorgi che ha dentro altri due require:

"PEAR.php" e "Spreadsheet/Excel/Writer/Workbook.php" che ha a sua volta gli altri require che ho elencato.

Comunque, dar un'occhiata alla guida che mi hai suggerito.

Ti ringrazio,

Puravida

risposto 8 anni fa
puravida
X 0 X

Credo di aver risolto il problema.

leggendo al guida che mi hai suggerito ho scoperto ch e mi mancava il pacchetto OLE nel quale sono contenuti i file oggetto dei require in questione.

Ti tengo aggiornato,

Puravida

:bye:

risposto 8 anni fa
puravida
X 0 X

:D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D

Questione risolta, era proprio la mancanza del pacchetto OLE, ora tutto funziona a dovere.

Ancora grazie,

Puravida

:bye: :bye:

risposto 8 anni fa
puravida
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda