problema caratteri speciali in Zend_PDF

Salve a tutti, ho un problema legato alla visualizzazione dei caratteri speciali nel pdf quando creo il file pdf con la libreria Zend_PDF. infatti se faccio stampare sul pdf uno dei caratteri: ò à ù è ì questi non mi vengono stampati. Come posso fare??? ci sono opzioni che risolvono questo problema?

ecco come effettuo attualmente la stampa su file

$page1->drawText(''.stripslashes($stampa['comunicazioni']), $page1->getWidth()-480,$page1->getHeight()-750);

inviato 8 anni fa
reve
reve
1
X 0 X

Puoi realizzare un piccolo script indipendente che riproduce l'errore?

Che versione del framework usi? Che set di caratteri usi per scrivere lo script PHP? Con quale editor?

 :bye:

risposto 8 anni fa
Gianni Tomasicchio
X 0 X

Ciao Gianni, approfitto per farti i miei auguri di buona pasqua.

Comunque la versione del framework è la 1.0.3, l'editor usato è Eclipse PDT, come script non uso alcuno script ma solo le funzioni della libreria Zend_PDF.

risposto 8 anni fa
reve
reve
1
X 0 X

prova con la versione 1.5 del framework

 :bye:

risposto 8 anni fa
Gianni Tomasicchio
X 0 X

Ciao a tutti  :)

Volevo sapere se l'upgrade alla versione 1.5 del framework ha risolto questo problema... Io non riesco a far stampare in pdf il simbolo .

Grazie in anticipo!

risposto 8 anni fa
gibson
X 0 X

non dovrebbero esserci problemi visto che è stato introdotto il supporto all'UTF

 :bye:

risposto 8 anni fa
Gianni Tomasicchio
X 0 X

Grazie della risposta Gianni  O0

Provvederò quindi ad aggiornare il framework.. ho letto che è sufficiente sostituire la library precedente con quella attuale, con in più alcune modifiche da apportare al codice, in particolare per le chiamate alle view action... però non mi è molto chiaro questo punto...

risposto 8 anni fa
gibson
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda