Non riesco a far leggere ad apache il file php.ini

Buon giorno a tutti,

(scusate per eventuali errori, per me è la prima volta in assoluto che scrivo qualcosa ad un forum)

prima di tutto complimenti per la guida dettagliatissima "Installare Apache 2.2, PHP 5.2 e MySQL 5 su Windows". Ho seguito passo passo varie volte tutto quello che c'è scritto, purtroppo sembra che abbia capito ben poco. Per l'ennesima volta ho installato Apache 2.2.8 seguendo tutte le istruzioni, poi ho scompattato php 5.2.5 nella cartella c:\php e li mi sono fermato perché quando lancio php.info l'istruzione (Configuration File (php.ini) Path mi punta su c:\Windows) e non c'è modo di cambiarla. Prima di disturbarvi ho cercato di leggermi tutte le info che ho trovato sul forum, ma non sono riuscito a risolvere il problema.

Riassumo tutti i passaggi che ho effettuato per giungere a questo punto:

S.O. Windows Vista (IIS disattivato)

Apache 2.2.8 (installato) Cartella C:/Program Files/Apache Software Foundation/Apache2.2

Php 5.2.5 (installato) scompattato nella cartella C:\Php

Mysql-essential-6.0.4-alpha-win32 (ancora non installato e l'unico che funziona con Vista)

Variabile d'ambiente settata:

C:\>path

PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Program Files\Zi

pGenius 6\;C:\Program Files\QuickTime\QTSystem\;C:\php

Aggiunte su file Httpd.conf di Apache (cartella conf):

#LoadModule version_module modules/mod_version.so

#LoadModule vhost_alias_module modules/mod_vhost_alias.so

LoadModule php5_module "c:/php/php5apache2_2.dll"

AddType application/x-httpd-php .php

PHPIniDir "C:/php"

<IfModule !mpm_netware_module>

<IfModule !mpm_winnt_module>

Immagine della pagina php.info :

Configure Command    cscript /nologo configure.js "--enable-snapshot-build" "--with-gd=shared"

Server API    Apache 2.0 Handler

Virtual Directory Support    enabled

Configuration File (php.ini) Path    C:\Windows

Loaded Configuration File    C:\Php\php.ini

PHP API    20041225

PHP Extension    20060613

Zend Extension    220060519

Debug Build    no

A questo punto non so davvero che pesci prendere. Se qualcuno mi può aiutare gliene sarei profondamente grato.

Grazie e saluti

inviato 8 anni fa
nccn
nccn
1
X 0 X

E' tutto ok, stai tranquillo!!! Non devi vedere "Configuration File (php.ini) Path" ma "Loaded Configuration File" che punta correttamente al tuo php.ini  O0

 :bye:

risposto 8 anni fa
Gianni Tomasicchio
X 0 X

Grazie mille, molto gentile. mi ha messo fuori strada l'immagine che c'è a pagina 3 di 8 della guida che fa intravedere il risultato di info.php.

Allora continuo ad installare il resto. di nuovo grazie e saluti.

risposto 8 anni fa
nccn
nccn
1
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda