php e apache

ciao gianni volevo chiederti una domanda,  ho istallato apache , tutto ok e php e mysql  , pero adesso apache mi da quest errore the requsted operation  has failed! perche secondo te  ?invece php quando funzionava tutto   ho inserito  un files per testare se funziona il php   phpinfo();   e vi fa scaricare il files  sapresti consigliarmi ciao

inviato 8 anni fa
roccochiolo
X 0 X

Se ti chiede di scaricare i file php significa che il PHP non è installato correttamente in Apache. Se fossi in te disinstallerei tutto e reinstallerei da zero, magari seguendo la guita che trovi sul sito.

 :bye:

risposto 8 anni fa
Gianni Tomasicchio
X 0 X

se posso permettermi di riagacciarmi a questo discorso:

allora ho formatato il pc ieri e ho rienstallato windows xp home edition...e ho fatto tutti gli aggiornamenti..compreso il service pack 3.

la cosa strana e che al momento di installare apache...senza ancora installare php e mysql vari...gia dopo l'installazione non va..mi da degli errori su dos...e in piu mi da sempre la stessa risposta "....has failed".

puo essere il server pack 3 faccia conflitto?

ho installato la 2.29 no ssl.

E che nell'installazione di apache ho seguito la guida alla lettera!:)

risposto 8 anni fa
Leorgrium
modificato 8 anni fa
X 0 X

hai per caso installato prima Skype?

risposto 8 anni fa
Gianni Tomasicchio
X 0 X

si perche?..comunque ho risolto...ho disinstallato dreamwaver..e magicamente va!infatto non l'ho mica capita sai...!^^

risposto 8 anni fa
Leorgrium
X 0 X

Dubito che dreamwaver possa centrare qualcosa. Il problema con Apache era certamente dovuto ad un altro programma che aveva occupato la porta 80 e Skype è uno di questi.

 :bye:

risposto 8 anni fa
Gianni Tomasicchio
X 0 X

ciao...mah allora ce modo per dire ad apache di mettersi in'unltra porta..perche me serve:)

risposto 8 anni fa
Leorgrium
X 0 X

Modo facile:

 - chiudi Skype

 - fai partire Apache

 - riapri Skype che trova la porta 80 occupata e ne usa in automatico un altro

Modo un poco più difficile

 - fregatene di skype che faccia quello che vuole

 - configura httpd.conf di apache per metterlo in ascolto su una porta diversa dall' 80

 - tutte le volte che richiami una pagina sulla tua macchina ricordati di specificare la porta perchè i browser vanno in automatico sulla porta 80

Magari se guardi nelle configurazioni avanzate di skype riesci a dirgli su che porta ascoltare e/o scrivere.. a memoria non ricordo però

risposto 8 anni fa
Gly
Gly
1
X 0 X

skype usa una porta sua ho visto..su impostazioni avanti ..una porta 333...ce la spunta per usare la porta 80 o 443...mah non è attiva.

il punto  e che anche se sconnetto skype....e mio amico apache non ne vuole sapere lo stesso di partire...:(

risposto 8 anni fa
Leorgrium
X 0 X

ora funzia!^^

so che ho un leggero problema..nell'installazione del mysql mi è venuta fuori proprio alla fine dell'installazione questa errore nella schermata di processing configuration...

x Apply security settings

the security settings could not be applied

error Number 1045.

Access denied for user 'root@localhost' (using password:YES)

che significa?^^

risposto 8 anni fa
Leorgrium
X 0 X

Sicuro che era la prima volta che effettuavi la configurazione di MySQL?

risposto 8 anni fa
Gianni Tomasicchio
X 0 X

no e la 2... perche l'avevi disinstallato soolo perche l'apache non funzionava..e avevo pensato di rifarlo da capo....solo che ce qualche file in rimasto in giro che fa conflitto?^^

risposto 8 anni fa
Leorgrium
X 0 X

riprova a disinstallarlo e a reinstallarlo

 :bye:

risposto 8 anni fa
Gianni Tomasicchio
X 0 X

gia fatto  ce una qualche configurazione che rimane in memeria...e non so cosa sia!:(

risposto 8 anni fa
Leorgrium
X 0 X

disinstalla mysql e poi vedi se tra i servizi di Windows ce n'è uno col nome "mysql", in tal caso va cancellato a mano

 :bye:

risposto 8 anni fa
Gianni Tomasicchio
X 0 X

Ciao ho letto il tuo problema con MySql dopo averlo disinstallato vai nella cartella programmi li troverai ancora la sua cartella cancellala o rinomila cosi dovrebbe andare, anche a me è successo le prime volte che installavo il tutto, poi ho capito dove stava l'inghippo :bye:

risposto 8 anni fa
scooby1574
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda