collegamenti persi

 :-[ Scusa Gianni non sapevo che per rispondermi dovevo ritrasmettere il quesito.

      Se costruisco una pagina in pippo/ufficio/scaffali.php

      e la vado a richiamare da pippo?sezione=scaffali non mi ritrovo con i collegamenti delle immagini

      e spesso devo sostiutire i percorsi con ../../../ ecc.

      Veramente questo succede non solo per le immagini ma anche per altri riferimenti (link).

      C'è qualcosa che mi sfugge e non capisco. Bisognerebbe utilizzare location?

      Se è così come si fa?

 :D E voilà.

Grazie per la risposta. :bye:

inviato 7 anni fa
tommy
X 0 X

Quando utilizzi nei link (URL, immagini, ecc.) dei percorsi relativi , ovvero quelli che non contengono il path completo al file ma solo l'ultima parte (magari con i ../../), devi tener presente che questi percorsi verranno trasformati in percorsi assoluti prendendo come punto di partenza, ovvero come cartella corrente, quella dell'URL visualizzato nel browser.

Se ad esempio nell'URL della pagina c'è scritto www.miosito.it/pippo.php?sezione=scaffali allora tutti i link con percorsi relativi verranno interpretati partendo da www.miosito.it.

Se invece nell'URL che mostra il browser hai www.miosito.it/pippo/ufficio/scaffali.php allora tuttti i link relativi faranno riferimento a www.miosito.it/pippo/ufficio/

 :bye:

risposto 7 anni fa
Gianni Tomasicchio
X 0 X

 :D Alla grande Gianni,

adesso vado a vedere come risistemare le cose.

Ti saluto cordialmente

P.S. - Questa cosa però non l'ho trovata in nessun libro/manuale.  Sembra quasi ovvia. Boh!   :(

risposto 7 anni fa
tommy
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda