Primo tentativo con zend framework

Salve a tutti, sono nuovo, mi chiamo Michele.

Mi sono deciso a provare zend framework per il mio prossimo cms.

Ho seguito i tutorial di phpnews.it ma dalla prima pagina di codice, vista la mia versione dello zend framework ( 1.9 ) ricevo messaggi di errore in quanto uso classi deprecate (ZendLoader).

ho riscritto quindi in questo modo:

set_include_path(get_include_path().PATH_SEPARATOR.'library'.PATH_SEPARATOR.'models');

include_once('Zend/Loader.php');

Zend_Loader_Autoloader::getInstance(); 

date_default_timezone_set ('Europe/Rome');

try{
   $db = Zend_Db::factory('Pdo_Mysql', array(
      'host'=>'localhost',
      'username'=>'root',
      'password'=>'root',
      'dbname'=>'propagator_zend'
   ));
   
   $db->getConnection();
} catch (Zend_Db_Adapter_Exception $e){
   die("Zend_Db_Adapter_Exception: ".$e->getMessage());
} catch (Zend_Exception $e) {
   die("Zend_Exception :".$e->getMEssage());
}

Zend_Registry::set('db',$db);

define('BASE_URL', str_replace('index.php','',$_SERVER['PHP_SELF']));
Zend_Controller_Front::run('controllers');

ma adesso ricevo come errore:

Class 'Zend_Loader_Autoloader' not found

sto cominciando a non avere le idee chiare, qualcuno mi puņ delucidare? grazie mille

inviato 7 anni fa
TrustWeb
X 0 X

scusate, spulciando ho trovato questo che spiega e da una soluzione

http://akrabat.com/2009/04/30/zend_loaders-autoloader_deprecated-in-zend-framework-18/#comment-28377

resterņ comunque attivo nella community, visto che i dubbi saranno molti.

a presto

risposto 7 anni fa
TrustWeb
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda

Domande simili