PHP, RSS, Safari4

Ciao! Primo Post!...... primo problema :-\

Questo il codice che genera un file rss:

$inizio  = "<?xml version="1.0\" encoding=\"ISO-8859-1\" ?>\n"; 
    $inizio .= "<rss version=\"2.0\" xmlns:dc=\"http://purl.org/dc/elements/1.1/\" xmlns:content=\"http://purl.org/rss/1.0/modules/content/\">\n";                                               
    $inizio .= "<channel>\n"; 
    $inizio .= "    <title>titolo</title>\n"; 
    $inizio .= "    <description>descrizione</description>\n"; 
    $inizio .= "    <link>link</link>\n"; 
    $inizio .= "    <copyright>Copyright © 2010 Nome. Tutti i diritti riservati.</copyright>\n"; 
    $inizio .= "    <generator>generatore</generator>\n"; 
    $inizio .= "    <language>it-it</language>\n"; 
    $inizio .= "    <ttl>60</ttl>\n\n"; 
     
    $array_rss = array(); 
     
    $query = "query che tira fuori la roba dal db per sbatterla nel rss"; 
                 
    $record = mysql_query($query); 
     
    $testo = ""; 
     
    while ($array_rss=mysql_fetch_array($record)) { 
        $testo .= "<item>\n"; 
        $testo .= "    <title>".$array_rss[1]." - ".$array_rss[2]."</title>\n"; 
        $testo .= "    <link>link</link>\n"; 
        $testo .= "    <description>\n        <![CDATA[".$array_rss[3].$array_rss[7]."]]>\n    </description>\n"; 
        $testo .= "    <dc:creator>creatore</dc:creator>\n"; 
        $testo .= "    <category>categoria</category>\n"; 
        $testo .= "    <pubDate>".date("F j, Y, g:i a")."</pubDate>\n"; 
        $testo .= "</item>\n\n"; 
    } 
     
    $fine  = "</channel>\n"; 
    $fine .= "</rss>\n\n";             
     
    $handle = fopen("rss/file.rss", "w");     
     
    fwrite($handle, $inizio.$testo.$fine);

Su windows, che tengo su parallel, con ie e ff si vede bene, mentre su safari con Leopard legge sempre e solo la prima news, senza altri messaggi di errore...

Suggerimenti??

Grazie in anticipo!!

inviato 6 anni fa
dks
dks
1
X 0 X

I messaggi di errore che ti segnala?

risposto 6 anni fa
Mario Santagiuliana
X 0 X

nessun messaggio di errore, č questa la cosa strana... semplicemente legge solo la prima news come se non ce ne fossero altre

risposto 6 anni fa
dks
dks
1
X 0 X

Non conosco safari ma suppongo si tratti di una sua configurazione.

La stessa cosa la fa anche con altri feed rss?

risposto 6 anni fa
Mario Santagiuliana
X 0 X

Non saprei, non credo si tratti di una configurazione strana, altri feed di altri siti li vedo bene... faccio prove su xampp in locale su macos X, potrebbe essere implicato? ma non saprei in che modo perņ, come ho detto ie e ff non hanno sti problemi...

risposto 6 anni fa
dks
dks
1
X 0 X

aggiungo che con vienna vengono letti tranquillamente, solo safari da sto problema

risposto 6 anni fa
dks
dks
1
X 0 X

Non conosco safari ma sospetto una sua configurazione.

risposto 6 anni fa
Mario Santagiuliana
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda