salve...

Premesso che nn sono molto ferrato in materie di php e database,mah diciamo che la base di installazione file php e inserimento tabelle fino a li ci so arrivare.

Allora..il mio problema e molto semplice..io ho scaricato  il tool PHPnews per creare le news sul mio sito e lo installato..dove l'ho allacciato "credo" corrente al database.

Ho una pagina news.php fatta di css/div/ e un paio di animazioni flash...dove al centro ce un mega div dove ho incluso la pagina php con questo codice:

<?php

include("news/news.php");

?>

e fin qui tutto liscio..nel senso che il database funziona..carico le news tranquillamente e su firefox si vede correttamente come voglio.

il mio problema sta nel fatto che solo su firefox si vede..perche se provo a caricare la pagina con safari,explorer o chrome...la pagina nn si carica nemmeno..e rimane schermata nera.

Qualcuno puo aiutarmi?magari a qualche forse è gia successo una cosa del genere...mi consigliarìte una soluzione?

anche perche se levo la riga php..la pagina torna a funzionare corrente.

ringrazio in anticipo per la risposte! :)

inviato 6 anni fa
Leorgrium
X 0 X

Lavori sempre in locale?

Ottieni errori particolari dal php? (leggi i log).

risposto 6 anni fa
Mario Santagiuliana
X 0 X

nn mi stampa alcun log..tutto funzia correttamente..

nn compare un msg di errore o righe sbagliate.

cioe la pagina proprio nn viene caricata..cioe nn fa neanche il tentativo di caricarla che viene fuori un schermata completamente nera senza scritte e senza nulla di nulla.

la cosa che mi consola e che su firefox funziona tutto alla perfezione..solo che nn posso far girare un sito solo su firefox..mi serve che almeno funzi su exploror e safari.

risposto 6 anni fa
Leorgrium
X 0 X

Non può non funzionare...

Se funziona con uno deve funzionare con gli altri...

Non può venire solo una pagina nera...il codice html arriva?

Sta in attesa di caricare la pagina?

risposto 6 anni fa
Mario Santagiuliana
X 0 X

eccomi..scusa per l'attesa..mah e state giornate movimentate queste:

allora..no..nn funziona...cioe la pagine funziona fino a quando nn metto il codice php.

Una volta inserito quello..la pagina si oscura..e nn carica.

Se lo tolgo..la pagina torna a comparire in tutti i brower.

http://leorgrium.altervista.org/news.php

Ho pensato che fosse un problema di script che nn funzionavano..magari imcompatibilità..pero tutte le prove portano sempre alla stessa cosa..

se metto il

<?php

include("news/news.php");

?>

dentro il div la pagina si oscura o nn carica!  :(

risposto 6 anni fa
Leorgrium
X 0 X

Output di errori?

risposto 6 anni fa
Mario Santagiuliana
X 0 X

nessun errore..

come puoi vedere anche tu..se apri la pagina con firefox..va...con exploror..fa schermata nera:)

risposto 6 anni fa
Leorgrium
X 0 X

Non ho IE per verificare.

Che versione usi?

Il codice html è visibile in IE?

P.S. l'immagine sottostante, è del Netter giusto? Attenzione ai copyright.

risposto 6 anni fa
Mario Santagiuliana
X 0 X

versione internet 8

mah anche con il safari fa lo stesso scherzetto ho notato.

solo firefox..funzia,che al cosa mi sembra altrettanto strana..

Si se faccio "codice html"..vedo tutto il codice html.

infatti nel div..dove c'è: include..vedo questo

<div class="newsex"> <!-- (c) 2003, 2005 PHPNews - http://newsphp.sourceforge.net/ -->
<script type="text/javascript"> 
<!--
        function sendtof(desktopURL)
        {
          desktop = window.open(desktopURL, "SendToFriend", "toolbar=no,location=no,status=no,menubar=no,scrollbars=yes,width=400,height=275,resizable=no");
        }
// -->
</script>
<h1 id="ni3">
   Prova
</h1>
<p>
   January 09, 2010, 10:33:35 PM by <a href="mailto:">admin</a> in . 
</p>
<p>
   <strong>sedie.ws  per i professionisti alla ricerca di sedie, tavoli, sgabelli, sedie ristorante..ecc</strong>
</p>
<p>
   <a href="/news.php?action=fullnews&amp;showcomments=1&amp;id=3">Full Story</a> | <a href="/news.php?action=fullnews&amp;showcomments=1&amp;id=3">Comments (3)</a> | <a href="javascript:sendtof('http://leorgrium.altervista.org/news/sendtofriend.php?mid=3')">Send To Friend</a> | 26 views
</p>
<hr />
<br />
<!-- (c) 2003, 2005 PHPNews - http://newsphp.sourceforge.net/ -->
 </div>
risposto 6 anni fa
Leorgrium
X 0 X

E' evidente che il tuo codice php funziona.

Devi ricontrollare il tuo codice html (di conseguenza l'output) che non viene interpretato correttamente dai motori di IE e Safari.

risposto 6 anni fa
Mario Santagiuliana
X 0 X

scusa la domanda idiota: mah come faccio a ricontrallare un codice..che di se per se funzia? ??? ???

nn sono una cima in queste cose..mah alla fine e una cosa stressante tutto cio visto che è in plug-in davvero ottimo per le news.

risposto 6 anni fa
Leorgrium
X 0 X

Devi rivedere il tuo codice html e/o css in modo che possa funzionare anche su altri browser web come IE e Safari...

Devi capire cosa fa visualizzare in modo scorretto la tua pagina a IE, che sezione di codice html.

risposto 6 anni fa
Mario Santagiuliana
X 0 X

emm..veramente la pagina se tolgo la dicitura  <?php...ecc>  torna a funzionare su tutti i browser,persino su Chrome di google..funzia!

e proprio l'implementazione di quella pagina php che rovina tutto...

ho fatto prove di  immettere un testo lunghissimo e funziona...ho provato a mettere pure una mega animazione in flash..e funzia...cioe e proprio quel pezzettino di codice il problema.

per il resto la pagina senza quel codice funzia benissimo,si visualizza benissimo..e nn da alcum problema di sorta...infatti e li la cosa strana.

Cioe mi fosse venuto fuori errore riga 108..o un avviso..sarebbe stato meglio..perche cosi avrei capito piu o meno dove era il problema..mah il fatto che nn da nulla.solo schermo nero..io brancolo nel buio piu totole...

Ora magari provo a vedere se su internet trovo un un'altro tool semplice per inserire le news come quello,anzi se ne hai uno da consigliarmi.te ne sarei grato! :)

risposto 6 anni fa
Leorgrium
X 0 X

Ripeto: se non hai errori nel codice php e puoi visualizzare il codice html (controllalo dall'inizio alla fine) in IE allora il problema non è il php e lo script phpnews.

Il problema è il codice html ed il css.

Devi vedere meglio come si presenta l'output di phpnews e cosa va a variare nella tua pagina.

Momentaneamente prova a metterlo in un iframe.

Non riceverai errori dal php perchè il problema sta sui client e sulla loro interpretazione del codice html.

risposto 6 anni fa
Mario Santagiuliana
X 0 X

Aggiungo: se con tidy html dai un occhio al codice html della tua pagina che è stata generata hai un sacco di errori.

Tag di apertura di alcuni div inesistenti per esempio.

risposto 6 anni fa
Mario Santagiuliana
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda