eliminare installazioni php e mysql problematiche e reinstallare

ciao, ho un vecchio pc win xp in cui ho dubbi riguardo alla corretta installazione di php e mysql (apache credo sia perfettamente funzionale), infatti non funzionano. Fino a qualche giorno fa quando lo accendevo la prima schermata che vedevo sul desktop riguardava un errore di mysqld.exe. Sapete dirmi come posso assicurarmi di eliminare completamente le installazioni e rifarle ex-novo?

grazie

inviato 6 anni fa
gabar-el
X 0 X

Ripercorre a ritroso le fasi di installazione potrebbe essere una soluzione.

Dopo aver rimosso normalmente i vari software non vedo perchè dovresti avere così tanti problemi a ri-effettuare una installazione di questi.

Mah...già che devi installare...perchè non provi una distro Linux e non provi a vedere come è lavorare su un server LAMP?

risposto 6 anni fa
Mario Santagiuliana
X 0 X

lavoro già su linux, ma su questo pc ho installato win xp e ho dei problemi da tempo. Mi farebbe comodo riuscire a reinstallare questi software. Forse proverò con xamp, ma non so perché quando provai mi dava una sensazione di poca libertà.... :(

risposto 6 anni fa
gabar-el
X 0 X
risposto 6 anni fa
Mario Santagiuliana
X 0 X

le ho provate un pò tutte. Ho installato e disinstallato immediatamente xamp (non mi piace).

Ora ho effettuato installazioni separate e pare tutto ok, se non quando provo a dirigermi verso l'installazione di un blog wp ricevo questo bellissimo messaggio:

'installazione PHP appare mancante dell'estensione MySQL che è necessario per utilizzare WordPress.

ho decommentato:

extension=php_mbstring.dll

extension=php_mysqli.dll

extension=php_mysql.dll

ho copiato il file della libreria libmysql.dll da mysql\bin nel \bin di apache

ma non è cambiato nulla

le versioni che sto utilizzando sono queste:

mysql 5.1.44

php 5.2.13

ho letto che forse può esserci incompatibilità

se visualizzo il phpinfo(); non vedo alcuna voce mysql...

che devo fare?

 :'(

risposto 6 anni fa
gabar-el
X 0 X

ho continuato a seguire la guida per cercare di risolvere.

ho creato uno script per il test di mysqli.

questo il risultato:

Warning: mysqli::mysqli() [mysqli.mysqli]: Headers and client library minor version mismatch. Headers:50051 Library:50144 in C:\Programmi\Apache Software Foundation\Apache2.2\htdocs\testmysql.php on line 2

Connesso con successo

risposto 6 anni fa
gabar-el
X 0 X

Con zend server ce tutti questi problemi non dovrebbero presentarsi.

Tu devi configurare correttamente il tuo php.ini.

La configurazione di tale file è rispecchiata nella pagina phpinfo che hai creato prima.

Ad ogni modifica del file php.ini devi riavviare apache.

Non devi fare spostamenti particolari di dll.

risposto 6 anni fa
Mario Santagiuliana
X 0 X

io ho seguito tutta la guida passo passo. non ho fatto alcun spostamento di troppo.

scusa ma non ho guardato il link che mi hai postato. vorrei solamente risolvere questo problema per andare avanti. sono sfinito e innervosito... :(

volessi provare con zend devo disinstallare qualcosa? Basta che lo installo e riga?

risposto 6 anni fa
gabar-el
modificato 6 anni fa
X 0 X

Per rispondere impiego parte del mio tempo...gradirei che venissero prese in considerazioni le proposte che faccio, se non sono bene accette basta dirlo ed evito di rispondere nella discussione.

Quale guida hai seguito esattamente? (link).

Puoi farci vedere il tuo php.ini?

Puoi riavviare apache e ricontrollare il tuo phpinfo?

risposto 6 anni fa
Mario Santagiuliana
X 0 X

Lo so, ti ringrazio infatti per il tuo tempo. Ma il tuo link diceva eventualmente di provare quello e io già capisco poco di ciò che conosco, per me le nuove proposte sono ben accette ma creano diffidenza per paura di dovere dedicare altro tempo a imparare altre cose.

la guida che ho seguito è questa

Questo il php.ini

non ho capito cosa dovrei controllare sul phpinfo...

grazie

risposto 6 anni fa
gabar-el
X 0 X
non ho capito cosa dovrei controllare sul phpinfo...

Se i moduli per connettersi a mysql sono caricati correttamente.

Zend Server CE è un'ottima scelta per installare un sistema amp in poco tempo, che sia funzionante e con le ottimizzazioni di zend per l'ambiente php, senza dover installare i vari software singolarmente.

Una lettura veloce della pagina di presentazione non porta via tanto tempo.

Il php.ini che ci hai dato mi sembra ad una prima lettura corretto, nel phpinfo dovresti vedere che i moduli per mysql sono caricati correttamente (riavvia il server apache ad ogni modifica del php.ini).

risposto 6 anni fa
Mario Santagiuliana
X 0 X

Ho disinstallato e risolto (per fortuna) con easyphp.

per ora tutto bene.

Terrò cmq presente zend server ce. Grazie per il consiglio e per l'aiuto.  :bye:

risposto 6 anni fa
gabar-el
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda