[Risolto] CIAO PHPNEWS!!!!

Ciao a tutta la community,

Sono un nuovo utente di phpnews pero grazie a voi ho imparato a programmare con php (o almeno ho imparato per cio che mi serve nel mio piccolo) grazie alle vostre giude ho risolte gran parte dei problemi che mi sono presentati lungo il percorso.

Ora dopo tutti questi ringraziamenti avrei una richiesta da portarti nella speranza di un vostro positivo riscontro.

Ho seguito alla lettera la vostra fantastica guida in merito alla configurazione di server php apache e mysql ormai impiegata in una decine di server perfettamente funzionanti e con nessun problema..

Da qualche giorno a questa parte pero stavo pensando di migrare le applicazioni con le nuove versioni di php ma la configurazioni mi pare ostia perche non ci sono piu le dll per apache come posso fare?!?!?

Grazie a tutti i moderatori per le risposte

inviato 6 anni fa
fractals87
modificato 6 anni fa
Mario Santagiuliana
X 0 X

Ciao, benvenuto.

1) Per curiosità: perchè non passare a server web linux?

2) Che tipo di problemi hai?

risposto 6 anni fa
Mario Santagiuliana
X 0 X

quelle che ho creato sono applicazione che di standard servono a interfacciarsi coi palmari e cell per interagire col db ma alcuni utenti lo utilizzano anche solo localmente e percui necessitano di una interfaccia windows (banale scusa per dire che so usare poco poco linux  :)) il mio preblema è legato che per far dialogare il web server e php in php c'erano proprio le dll di apache da caricare nel conf con il load module.. a differenza che nel php5.3 non c'e.... piccola curiosità ho visto anche un softwarino che ZEND studio che installa automaticamente tutto cosa potete consigliarmi?

risposto 6 anni fa
fractals87
X 0 X
php c'erano proprio le dll di apache da caricare nel conf con il load module

Continuo a non capire il tuo problema...php lo puoi caricare come modulo di apache con loadmodule nel file di configurazione di apache.

Le estensioni di php le carichi nel php.ini.

Questa guida non ti è di aiuto?

http://www.phpnews.it/articoli/installare-apache-22-php-52-mysql-5-su-windows/

risposto 6 anni fa
Mario Santagiuliana
X 0 X

la guida, quella che ho sempre seguito io, dice di aggiungere il loadmodule nel conf di apache

1.LoadModule php5_module "c:/php/php5apache2_2.dll"

2.AddType application/x-httpd-php .php

3.PHPIniDir "C:/php"

nella versione 5.2 questa dll c'e ma nella versio 5.3 di php non c'e questa dll

risposto 6 anni fa
fractals87
X 0 X

Non uso windows e non ho modo di provare.

Sei sicuro di aver scaricato il pacchetto giusto?

risposto 6 anni fa
Mario Santagiuliana
X 0 X

si putroppo si...

risposto 6 anni fa
fractals87
X 0 X

Mi sembra impossibile che hai questo problema...Il VC9 installer?

risposto 6 anni fa
Mario Santagiuliana
X 0 X

io vado qui per scaricarlo http://windows.php.net/download/

ho scaricato PHP 5.3 (5.3.2) VC9 x86 Non Thread Safe (2010-Mar-04 20:11:07) ZIP

perche consigliato anche dalla guida.. l'installer nn so come funzione...

Ho provato a riscaricarlo ora ma questa dll c:/php/php5apache2_2.dll manca e nn ce ne sono di simili con la dicitura apache

risposto 6 anni fa
fractals87
X 0 X

Usa questo pacchetto: VC9 x86 Thread Safe.

O altrimenti VC6 x86 Thread Safe con php5apache.dll.

ll VC9 x86 Non Thread Safe non supporta apache.

risposto 6 anni fa
Mario Santagiuliana
modificato 6 anni fa
X 0 X

ma vaaaaaaaaaaaaaaa per una cosa cosi semplice ho piantato giu un casino che la meta bastava.... scusate per la discussione inutile e grazie mille ciao ciao

risposto 6 anni fa
fractals87
X 0 X

Allora problema risolto? :D

risposto 6 anni fa
Mario Santagiuliana
X 0 X

si c'e la dll penso che nn ci siano problemi nei prossimi giorni faccio un paio di test

risposto 6 anni fa
fractals87
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda