PHP 5.3 e Apache

Ho sempre seguito meticolosamente la guida di configurazione ora vorrei configurare php 5.3 ma ho una difficolta non riesco a caricare l'estensione di mysql manca il file libmysql.dll come posso fare?!?

Ciao a tutti e grazie delle risposte

inviato 6 anni fa
fractals87
X 0 X

Gi letto questa discussione?

P.S. l'hai creata pure te...

risposto 6 anni fa
Mario Santagiuliana
X 0 X

si scusami hai ragione infatti l'avevo cercata perche volevo rispondere la ma non trovandola avevo pensato che era stata cancellata... il problema del file phpapche2_2 stato risolto pero ora mi trovo di fronte a questo nuovo problema quella libreria li non presente nel pacchetto che mi avevi fatto scaricare al tempo..

risposto 6 anni fa
fractals87
X 0 X

Non c' la libreria mysql.dll? (non ho scaricato l'archivio per controllare al suo interno).

Non riesci a connetterti al database?

risposto 6 anni fa
Mario Santagiuliana
X 0 X

no sembra proprio che non sia supportata nella nuova versione l'intera libreria mysql

risposto 6 anni fa
fractals87
X 0 X

Per completezza e precisione. Che versione hai scaricato?

risposto 6 anni fa
Mario Santagiuliana
X 0 X

http://www.php.net/manual/en/migration53.incompatible.php

questp delucida il problema ma nn ho trovato una soluzione in merito ancora

risposto 6 anni fa
fractals87
X 0 X

Puoi cortesemente rispondere alla mia domanda?

risposto 6 anni fa
Mario Santagiuliana
X 0 X

php-5.3.2-Win32-VC9-x86.zip questa la versione che ho scaricato che era poi la versione che mi avevi consigliato tu per trovare la libreria di apache.

risposto 6 anni fa
fractals87
X 0 X

Sotto la cartella ext hai queste librerie che puoi usare:

php_mysql.dll

php_mysqli.dll

php_pdo_mysql.dll

risposto 6 anni fa
Mario Santagiuliana
X 0 X

e dove posso trovare documentazioni dettagliate su come caricarle e poterle utilizzare..

risposto 6 anni fa
fractals87
X 0 X

Il pacchetto scaricato contiene dei file molto utili per la documentazione. Ad esempio:

install.txt

Contiene anche dei file di configurazione di php.ini di esempio:

php.ini-development

php.ini-production

Devi semplicemente impostare correttamente il tuo php.ini, decommenti ad esempio:

; extension=php_mysql.dll
risposto 6 anni fa
Mario Santagiuliana
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda