errore mysql

ciao a tutti! Sono nuovo di questo forum che, fino ad ora mi stato di grande aiuto!

Uso php da alcuni mesi, lo configurai seguendo questa guida http://www.youtube.com/watch?v=Els0EDM1-So.

Oggi ho voluto provare ad usare mysql e il csm wordpress, ma seguendo la guida precedente ho avuto qualche problema!

Quando vado su localhost/wordpress (cartella in cui l'ho installato), non riesco a cominciarne la configurazione a causa di questo messaggio d'errore "L'installazione PHP appare mancante dell'estensione MySQL che necessario per utilizzare WordPress."

Non ho ben capito come inserire questa estensioni. Come posso risolvere? Grazie :)

SO: Windows Seven 64x

programmi:

Apache 2.2.14

PHP 5.2.12

Mysql 5.1.53

inviato 6 anni fa
Rochus
X 0 X

Nel tuo php.ini devi decommentare la riga per il caricamento del modulo mysql.dll.

risposto 6 anni fa
Mario Santagiuliana
X 0 X

grazie mille per la risposta :)

ho seguito la vostra guida da zero e ho fatto la modifica che hai detto.. ma riavviando apache e avviango la pagina con phpinfo(), nell'elenco non trolo la tabella mysql! (mi riferisco a questa guida: http://www.phpnews.it/articoli/installare-apache-22-php-52-e-mysql-5-su-windows/6/)

risposto 6 anni fa
Rochus
X 0 X

facendo il test l'errore :

Fatal error: Call to undefined function mysql_connect() in C:\ .... on line 2

risposto 6 anni fa
Rochus
X 0 X

Hai decommentato la riga per caricare le estensioni di mysql? Se si e non si vedono nel phpinfo riavvia apache, vedi se si vedono.

Ciao

risposto 6 anni fa
Mario Santagiuliana
X 0 X

si ho levato il ; sia da msql.dll che da php_mysql.dll

risposto 6 anni fa
Rochus
X 0 X

Bene, riavvia apache, il phpinfo che ti dice? Che le estensioni sono caricate?

risposto 6 anni fa
Mario Santagiuliana
X 0 X

purtroppo no!

possibile che la versione che ho scaricato di mysql 5.1.53 non sia pienamente compatibile con PHP 5.2.12 ? .

risposto 6 anni fa
Rochus
X 0 X

Il problema non mi sembra di mysql ma di php che non carica la libreria necessaria per la connessione al database.

risposto 6 anni fa
Mario Santagiuliana
X 0 X

c' qualche libreria che devo controllare? :S

grazie ancora per il supporto!

risposto 6 anni fa
Rochus
X 0 X

Si mysql.dll, e l'installazione dei componenti per creare il tuo server...

risposto 6 anni fa
Mario Santagiuliana
X 0 X

avevo php_mysql.dll e msql.dll (entrambi abilitati) ma non ho trovato mysql.dll >.<

risposto 6 anni fa
Rochus
X 0 X

OK...che versione di php hai installato? Che pacchetto hai scaricato?

risposto 6 anni fa
Mario Santagiuliana
X 0 X

Apache 2.2.14

PHP 5.2.12 (non l'installer)

Mysql 5.1.53

risposto 6 anni fa
Rochus
X 0 X

Rivedi l'installazione del tuo php, esiste anche una versione pi aggiornata di php, prova a vedere.

Pi semplice utilizzare o una distro linux o un pacchetto completo tipo xampp.

risposto 6 anni fa
Mario Santagiuliana
X 0 X

si ti ringrazio :) faccio diverse prove, intanto sto usando easyphp, che a quanto pare mi permette di fare tutto quel che ho bisogno di fare!

Grazie mille per il supporto!

risposto 6 anni fa
Rochus
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda