ZendServer: non mi apre pagine .php

Salve a tutti,

ho installato da poco, in locale ZendServer community edition.

dovo aver avviato il server, se vado su

https://localhost:10082/ZendServer

mi fa accedere al pannello di gestione del server.

Ora se provo a mettere un file .php nella cartella /usr/local/zend/apache2/htdocs e lo seleziono sulla barra del browser, quando clicco non mi apre la pagina web ma mi da una schermata in cui mi chiede con quale programma devo aprire il file

vorrei poter utilizzare il tutto come facevo prima, dovo aver installato apache, mettevo i file nella /var/www e mi bastava scrivere sul browser http://localhost e mi faceva vedere le pagine sul browser.

cosa mi perdo??

Grazie 1000!!!

inviato 6 anni fa
blow1986
X 0 X

nel pannello di gestione del server va su server info e riporta la schermata

risposto 6 anni fa
civre
X 0 X

Ciao! scusa il ritardo nella risp, ma ho avuto problemi col pc :(

Zend Server Community Edition

Version 5.0.3

PHP

Version 5.3.3

PHP Configuration File /usr/local/zend/etc/php.ini

Web Server

Server Name localhost

Server Software Apache/2.2.15 (Unix) mod_ssl/2.2.15 OpenSSL/0.9.8n PHP/5.3.3

OS Version Linux

Zend Framework

Version 1.10.8

Installed Path /usr/local/zend/share/ZendFramework

Zend Data Cache

Version 4.0

Status On

risposto 6 anni fa
blow1986
X 0 X

Scusa ma che indirizzo inserisci nella barra del browser?

risposto 6 anni fa
civre
X 0 X

con http://localhost cosa visualizzi?

risposto 6 anni fa
civre
X 0 X

con http://localhost/ visualizzo la cartella /www in quanto prima di installare ZendServer CE, ho scaricato Apache, MySql e installato PHP (sotto ubuntu).

qui funziona tutto, e quando apro una pagina in php, mi apre lo scipt nel browser.

Mentre se vado nella Document Root a cui punta il ZS, e metto una pagina in php, quando la apro non mi gira.

risposto 6 anni fa
blow1986
X 0 X

Avvia solo zend server ce. Non avviare l'apache fornito da ubuntu.

Rivedi dunque la configurazione di apache per indicargli dove deve "puntare" per la documentroot.

risposto 6 anni fa
Mario Santagiuliana
X 0 X

Ciao.

ho stoppato apache avviato da ubuntu (infatti se vado su http://localhost) mi da errore.

ed avviato solo ZS.

in php.info mi da DOCUMENT ROOT (sotto Apache Environment) /usr/local/zend/gui/UserServer

e come SERVER ROOT /usr/local/zend/apache2

ho provato a mettere uno script sotto la document root, ma ancora niente...

sempre la stessa cosa

risposto 6 anni fa
blow1986
X 0 X

Come hai installato zend server ce?

Vedi le FAQ:

http://www.zend.com/en/products/server/faq

risposto 6 anni fa
Mario Santagiuliana
X 0 X

ho fatto il download dal loro sito web.

e installato normalmente.

probabilmente mi tocca reinstaller tutto..

risposto 6 anni fa
blow1986
X 0 X

ti segnalo una cosa strana:

se sul browser scrivo http://localhost:10083/ (la 10083 la porta che mi segnala il phpinfo di ZS)

mi appare questo messaggio nel browesr:

The requested URL is not valid for browser access, for internal Zend Server UI use only.

????

Grazie

risposto 6 anni fa
blow1986
X 0 X

Segui l'installazione utilizzando i repo per ubuntu. Ti semplifica la vita e l'aggiornamento del software.

Poi vediamo dove stanno gli errori.

risposto 6 anni fa
Mario Santagiuliana
X 0 X

sto seguendo qualche guida per installare tramite apt-get, ma non riesco ad andare avanti:

aggiungo la repository:

deb http://repos.zend.com/zend-server/deb server non-free

poi:

wget http://repos.zend.com/deb/zend.key -O- | apt-key add -

apt-get update

ma gia nell'update mi esce fuori questo:

W: Impossibile recuperare http://repos.zend.com/zend-server/deb/dists/server/non-free/binary-i386/Packages.bz2 Somma hash non corrispondente

e quando infine do:

sudo apt-get install zend-server-ce-php-5.3 zend-server-framework-extras

mi dice:

Il pacchetto zend-server-ce-php-5.3 non ha versioni disponibili, ma nominato da un altro

pacchetto. Questo pu significare che il pacchetto mancante, obsoleto

oppure disponibile solo all'interno di un'altra sorgente

E: Il pacchetto zend-server-ce-php-5.3 non ha candidati da installare

risposto 6 anni fa
blow1986
X 0 X

1) Che guida stai seguendo?

2) attento all'architettura del tuo kernel.

Ciao

risposto 6 anni fa
Mario Santagiuliana
X 0 X

mmm.. ne ho provate molte..

ma fino ad ora ho trovato sempre le stesse info

risposto 6 anni fa
blow1986
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda