errore sulle InfoPHP

Ciao,

ho un problemino con la pagina (index.php) dove ho inserito la stringa <?php phpinfo(); ?> per testarne il funzionamento.

Il file index.php l'ho inserito in c:/php/www, ho configurato il file php.ini (in auge php.ini-development) e il file httpd.conf

Se digito da prompt del dos: php -v tutto corretto, le versioni di php e apache sono php5.3.6 (i sorgenti) e 2.2.18 l'installer.

Potete per cortesia dare un'occhiatina ai file httpd.conf e php.ini? e dirmi dove sbaglio?

Premetto che da quando ho fatto le modifiche il server apache non parte.

Per evitare di fare il copia e incolla del testo dei due file, ve li posso spedire.

Grazie

inviato 5 anni fa
abex
abex
1
X 0 X

Quando tenti di far partire il server, hai degli errori?

Io farei cos: fai una copia dei tuoi file httpd.conf e php.ini, poi reinstalla quelli originali e fai un diff.

Per fare il diff puoi usare WinMerge

risposto 5 anni fa
Massimiliano Arione
X 0 X

Ciao,

qando avvio il server apache mi compare il messaggio "The requested operation has failed!" guarda caso mi ero fatto una copia dei due files, e ho scoperto che l'errore riferito alla stringa che ho inserito dopo i loadmodule, la stringa dovrebbe indicare ad apache il percorso da seguire per localizzare i moduli PHP.

# Start Php integration

LoadModule php5_module "c:/php/php5.dll"

AddType application/x-httpd-php .php

PhpIniDir "C:/php"

#End Php integration

Ho ricontrollato la path (directoryroot..) ed corretta.

La versione di Apache installata 2.2.18 (installer)

La versione di PHP la 5.3.6 (sorgenti, il nome del file : php-5.3.6-nts-Win32-VC9-x86.zip)

Grazie

risposto 5 anni fa
abex
abex
1
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda