Script per ultimi 10 post in forum

Ciao a tutti:

ho creato uno script che mi dovrebbe stampare i titoli degli ultiml 10 topic con link che rimanda a questi ultimi,lo script è questo:

<?php
//mi connetto al database
$DB_host     = 'ILMIOHOST';
$DB_user     = 'ILMIOUSER';
$DB_password = 'LAMIAPASSWORD';
$DB_name     = 'ILNOMEDELDB';
 
$link = mysql_connect($DB_host, $DB_user, $DB_password);
if (!$link) {
   die ('Non riesco a connettermi: ' . mysql_error());
}
 
$db_selected = mysql_select_db($DB_name, $link);
if (!$db_selected) {
   die ("Errore nella selezione del database: " . mysql_error());
}
//prendo i post
$result = mysql_query('SELECT topic_id AND topic_title AND forum_id FROM phpbb_topics ORDER BY topic_time DESC LIMIT 0,5');

while($result = mysql_fetch_array($result)

    echo '<li><a href="http://www.atomicteam.site40.net/Forum/viewtopic.php?f={$result[forum_id]}&t={$result[topic_id]}">{$result[topic_title]}</a></li>';
echo "</ul>";
?>

Lo script mi restituisce questo errore:

Parse error: syntax error, unexpected T_ECHO in /home/a6351547/public_html/destra.php on line 86

Se mi sapreste spiegare il problema mi sareste grati

A presto  :bye:

inviato 5 anni fa
edo1998
X 0 X

prova così

<?php
//mi connetto al database
$DB_host     = 'ILMIOHOST';
$DB_user     = 'ILMIOUSER';
$DB_password = 'LAMIAPASSWORD';
$DB_name     = 'ILNOMEDELDB';
 
$link = mysql_connect($DB_host, $DB_user, $DB_password);
if (!$link) {
   die ('Non riesco a connettermi: ' . mysql_error());
}
 
$db_selected = mysql_select_db($DB_name, $link);
if (!$db_selected) {
   die ("Errore nella selezione del database: " . mysql_error());
}
//prendo i post
$result = mysql_query('SELECT topic_id AND topic_title AND forum_id FROM phpbb_topics ORDER BY topic_time DESC LIMIT 0,5');

while($result = mysql_fetch_array($result))
{
    echo '<li><a href="http://www.atomicteam.site40.net/Forum/viewtopic.php?f={$result[forum_id]}&t={$result[topic_id]}">{$result[topic_title]}</a></li>';
echo "</ul>";
}
?>

dovrebbe funzionare tranquillamente  :bye:

risposto 5 anni fa
SuperSavio
X 0 X

ho dovuto fare qualche altra modifica ma ha funzionato!

Grazie  :bye:

risposto 5 anni fa
edo1998
X 0 X
Effettua l'accesso o registrati per rispondere a questa domanda

Domande simili